1080x1920 footage results in black screen


#1

New to Mocha AE. I’m trying to import and track .mp4 footage that was shot 1080x1920. Anytime I try to work with this aspect ratio, I only get a black screen. However, all HD footage (1920x1080) shot with the same camera and same codecs loads fine. Even though I imported from an After Effects project with settings of 1080x1920, the Mocha settings are the reverse: standard 1920x1080. I’ve tried figuring out if there’s a way to manually adjust the aspect ratio within Mocha AE, but so far no luck. Any advice on working with unconventional aspect ratios such as this? I’d think there must be an easy solution.


#2

Mocha prefers .MOV files to MP4s, and you must have Quicktime codecs (Quicktime Essentials is all you need) installed. There are certain types of codecs and file types that Mocha does not support, usually native, unprocessed codecs off of cameras and AVIs on Windows. You mayneed to convert the file to something Mocha supports, such asquicktime or an image sequence. If your screen is black or white for clips but not for images, it is most likely the codec for the movie files that is causing the issue. View Documentation: supported file list Other troubleshooting tips:

  • Double-check that your quicktime drivers, codecs, and video card drivers are up to date, and that quicktime can open the file.
  • Try changing your codec to a more widespread codec. Usually any other quicktime format like animation, h.264, or JPEG compression should work, or another type of common .avi compression.
  • If the footage loads in quicktime but not in Mocha , try converting the clip to a file we know for sure that Mocha recognizes, like a TIFF or JPEG sequence, to test and make sure that Mocha is running properly.

#3

Thanks Mary for the suggestions. I tried them with interesting results. In the end, converting a 1080x1920 clip to TIFF sequence works. However, I’d suggest Mocha trying fix this bug on the software end, especially as phone-friendly aspect ratios will only become more common. Here’s info on what doesn’t work:

-1080x1920 video clips in H.264 / .mp4
System:
-Windows 10 with Quicktime installed
-Mocha AE within After Effects (Adobe Cloud)

Files open in Quicktime but NOT Mocha. Black footage screen appears in Mocha.
Same footage shot in standard 1920x1080 opens fine.


#4

It isn’t a bug, it’s simply that we do not support that footage. If you use the Mocha Pro plugin, it reads off your host timeline, and so it will read whatever codec the host can process, and you might find that more convenient. But since we use a limited quicktime engine in the Mocha AE standalone, we can’t read some types of footage.


#5

Might be more tricky anyway, it’s not only the format.
Phone footage can have varying frame rates, which are quite problematic.


#6

As mentioned, it isn’t the camera or codec causing problems but the 1080x1920 aspect ratio. Seems Mocha AE doesn’t handle this.


#7

The aspect ratio should not matter, you can simply set it to custom.