2022.5 - Spline points don't always move when I drag them

I just updated to 2022.5 after not having used Mocha Pro since January (so I don’t know which version introduced this issue), and now it seems sometimes my spline points don’t want to immediately drag when I click-drag them. I can only consistently get them to drag if I hold down on the mouse for a second before trying to move them. If I drag before holding it there a second, sometimes the points just stay still, as if I had only clicked them, instead of dragged them.

EDIT: Having it occur a few more times tonight, I notice it seems to happen more the more spline keyframes I have.

Just to be sure, are you on v9.5.3, the most recent version of 2022.5 as of this post?

Are you using any mesh tracking, or just the planar track?

Yeah I just updated the other day. Checked and it is indeed 9.5.3.

I’ve experienced this both with mesh tracking and planar tracking.

In case you need to know, I’m using an RTX 3080 Ti on the latest studio driver

More questions! Sorry, this helps me narrow down the problem:

  1. If you’re in After Effects, are you using any third-party scripts, plugins or panels?
  2. Do you use a mouse or a wacom tablet?
  3. Can you attach your Mocha log from Help > view log please?

Using the After Effects plugin, yes, and with a mouse. No third party stuff. Here’s the log:

mocha.log.txt (4.6 MB)

Waited for a session that resulted in this issue again before grabbing the log. I noticed that the movement of the points (after I hold down the mouse for a second) gets laggier too, like the frame rate of the screen displaying the spline reduces.

EDIT: Tried closing the Mocha window and reopening it, and the lag went away! Maybe that will help you figure out what’s going on.

For a start, i’d recommend reducing your texture RAM in Mocha GPU preferences down to about 512. You do not need to assign that much texture RAM for display and it could impact performance. you’ll need to reboot Mocha after this change. I’d restart AE as well just to make sure the preference change sticks.

What is your AE memory allocation for other applications?

We’ve seen this point lag occur sporadically on a few other artists’ systems, but we’ve not been able to find a direct cause as we’re unable to reproduce it locally.

Okay I’ll try that. I set it to about 4GB because my GPU has 12GB so I figured why not make a larger pool available just in case. Figured the number was small enough relative to the total VRAM that it wouldn’t impact anything, but I suppose I don’t know how Mocha handles that allocation under the hood.

Looks like I have 6GB reserved for other applications in AE. I have 64GB total RAM.

Still happening after changing to 512 and restarting everything.

I’d suggest upping that AE application reserve allocation to about 12-16GB, but TBH I’m just testing the waters here. We’re not really sure what is causing this yet. This seems to be related to interaction of points specifically, which shouldn’t be affected by RAM.

Can you also please go back to your GPU page and explicity select your display GPU from the the opencl device list, rather than setting “Automatic” please?

I will do these things to test it, but the AE memory allocation setting will have to be temporary, as there are some After Effects projects I create where AE needs to make use of every available GB of RAM I let it, and reducing that by 6-10GB can significantly slow those projects down.

I can’t imagine selecting the GPU setting specifically will do anything as I only have one GPU. Nothing on the motherboard and no other cards, and GPU processing appears to work fine. But I’ve selected it now anyway.

Another observation I’ve had is that sometimes it looks like the point starts dragging, and then snaps back to where it was before moving again, and lags behind the mouse cursor’s position when that happens. Other times it just doesn’t move at all unless I’ve held my mouse down for a second or so before dragging.

While my original assumption was that the cause may be based on the number of keyframes, it seems it may be caused by having the mocha window open longer than usual, as closing the mocha window and opening it back up from the plugin causes performance to return to normal. Or perhaps it’s a combination of both things. Maybe background threads that get stuck, causing other threads to wait, or memory leaks, or issues with temporary cache? Stuff like that could certainly reset when the window was closed and reopened. I am fairly certain I didn’t have this problem in the version I was using back in December and January, which would have been the newest version available back then. So I would assume something that changed in the code between those versions was the culprit.

Do you ever end up with a “failed to restore object state” error?

Now that you mention it, I think I did see that error one time. I think it might have been the first or second time I ran into this issue. It was after I had tried to drag a point a few times and it didn’t move.

Still happening even increasing the After Effect RAM reserved for other apps to 16GB, and manually selecting the GPU in Mocha

Noticed something when it happened this time. In task manager, mocha is showing 6 GB of RAM being used, and when I close and reopen the window, it’s 350 MB. So maybe memory is a factor, but Mocha does have access to plenty more than that, so I’m not sure.

This current shot is complex, 450 frames, and requiring a lot of manual adjustment of the spline for roto. I’ve had to close and reopen mocha several times already because it kept doing this.

Thanks for the updates. Memory usage of 6GB is pretty normal, so I don’t think that will be the contributing factor.

We’re compiling a list of cases where this happens to see if there is any correlation. So far the only shared factor is Windows.
We’ve seen it happen to approximately 4-5 people over the last year or so but it’s still been impossible to reproduce anywhere else. I’m asking the dev team if there is another way we can capture what is happening.

It would help to know if there is anything else running on your system outside of the usual Windows processes. Additional tools, dock widgets, third-party windows utilities etc. We’re trying to narrow down the common theme.

The only other things I’m running while I’m doing this are Chrome, Premiere, and Excel, in addition to After Effects of course. Google Drive and Steam are also running in the background, but won’t be actively doing anything during this.

I had an idea. I decided to try Mocha AE for shots I didn’t need Pro features on, and while performance did degrade over longer sessions, meaning when dragging spline points, the frame rate of the spline display slowed down over time, making it feel sluggish, it never blocked me from moving a point like was happening on Pro. I did notice Mocha AE was an earlier version than Pro

I had a new observation. As explained before, the performance of dragging points degrades over time, starting out at a smooth frame rate, and getting laggier and laggier the more keyframes you start adding, when performance gets poor enough is when points start refusing to move when dragging.

However, once dragging spline points has a low frame rate, I noticed something. If I create a new spline layer, that new layer doesn’t have any performance issues, but when I switch back to the previous layer, it’s still laggy. So this issue appears to happen on a per layer basis.

As I said before, it doesn’t appear to be based on total keyframes, as closing the window and reopening it causes performance to go back to normal for a while, so it appears to be linked to how many keyframes you added to the currently selected layer since opening the mocha window. Saving doesn’t impact this, nor does clearing cache.

That IS interesting! Thank you for your continued posts on this. I’ll add your comment to our defect ticket to see if it helps narrow down the problem for the dev team.

1 Like