AE-CC2017 Mocha Corner Pin Export not Working

I recently upgraded to After Effects CC, and got the latest (CC2017) version. I haven’t been doing a lot of work that required tracking in quite some time, but found it easy to jump back in with MochaAE, and was doing nice Roto work for my scene.
But all joy ended abruptly when my Corner Pinning has repeatedly failed.
I scoured the forums and tutorials for hints as to why I could no longer do what I have taken much pride in doing.
My image (for corner pinning) is the same size as my Comp, and I am using the latest MochaImport+ for the import … trying Red Giant Warp, the AE Corner Pin, etc., and the image seems to be rock solid in tracking and size, but appears to be sitting far forward in Z space and off on the X axis to the right - but tracks solidly. It is in this same off position no matter how I try to corner pin it.
I’m OK with working to solve it (I rather enjoy the challenge), but in this case, this is for my Granddaughter’s school project that is due in a couple of days.
I beg you for your help!
Many thanks in advance … Bob

Hi Bob,

Can you send a screenshot of your surface tool inside of mocha, your corner pin inside of AE, and your project settings in both mocha and AE projects? It’s likely there’s a mismatch somewhere.

Let me know? We should get you sorted soon.


Hi Mary! Thanks lots for your help! I sent the link to your email acct too. I hope I included everything you asked for to get us started. I did really miss learning new things using Mocha, and am back now for a long time I hope! Hoping all is well …

Your keyframes are off. Looks like your trimmed the clip in mocha but not in AE. Move your input back to the first frame in mocha and trim the layer instead of the mocha timeline.

Should it look like this instead? Sorry I’m a bad student (pain in the A**) today, but I promise I’ll put in the work to get caught up.
Here’s the updated link (I added a screen shot of what I think you told me to do named “Like This?”).
Thanks ever so much again Mary!

Yes, try like that. And if that doesn’t work, simply slide the keyframes over in AE from frame 1 to frame 53. :slight_smile:

So Sweet! That solved it! I’m thinking I must have known this once in my life …
Have a super day!

Hello Mary,
I am having the same issue and I cannot find a solution to it. My biggest problem in my project is that I have been doing the same exact thing over and over and it stopped working out of nowhere…

To my project:
I am removing objects from a scene using clean plates and for each element I intend to remove, I do a track of its position in the shot to avoid drifting. I apply the corner pin to my clean plate and mask out the area I need to use for my cleaning.
Both settings match, frame rates included. I used my align surface tool on the frame I painted on ( frame 110 ) and did my corner pin paste on the first frame of my comp in AE. That worked for all of my layers until now. But now whatever I try to do, my corner pin is off in X and Y, even if I use a Solid matching the comp size. I cannot figure out what I do wrong or what isn’t working properly, I have been trying around and looking for solutions for a while now, no success…

Is someone able to spot a mistake and help me?

Thanks in advance!

P.S: I am trying to remove that tree in the foreground now, I intend to do it using three tracks because of the parallax problem occuring due to the height of the tree.