AE to Mocha Pro?

Hi everyone,

I was under the impression that when you have a clip in a comp (in AE) that you want to track in Mocha,

that when you select the “track in Mocha AE” that it would not only launch Mocha, but place the footage (trimmed) into a mocha project.

In other words, send that clip info to Mocha.

Am I mistaken, wasn’t that a function of the AE to Mocha workflow?

All I’m getting is a launch of Mocha with a empty open clip dialogue.

 

Any help would be appreciated.

Thanks, Andrew

Hi Andrew.

It sounds like you’re using a codec mocha doesn’t like. There are certain types of codecs and file types that mocha does not support, usually native, unprocessed codecs off of cameras and AVIs on Windows. You may need to convert the file to something mocha supports, such as quicktime or AVI with a basic codec or an image sequence. If your screen is black or white for clips but not for images, it is most likely the codec for the movie files that is causing the issue.

Keep in mind the Codec is not the same thing as the file type, it sounds like you have a codec problem. A codec is the type of compression, the file type is AVI or MOV.

View Documentation: supported file list http://www.imagineersystems.com/support/documentation/#File_Formats

Other troubleshooting tips (because this sounds like it may be a driver or installed codec issue instead of a format issue):

Double-check that your quicktime drivers, codecs, and video card drivers are up to date, and that quicktime can open the file. (The most likely cause to these formats you listed not working is probably that the codecs need to be updated on your machine). But currently, DNXHD is not on our supported list.

Try changing your codec to a more widespread codec. Usually any other quicktime format like animation, h.264, or JPEG compression should work, or another type of common .AVI compression.

If the footage loads in quicktime but not in mocha, try converting the clip to a file we know for sure that mocha recognizes, like a TIFF or JPEG sequence, to test and make sure that mocha is running properly.

mocha supports most standard movie clip and image sequence formats. In order to use clips (ie. not image sequences) you must have QuickTime installed. Level of QuickTime support can vary depending on the operating system.

What to Do if mocha Does Not Support Your Footage

In the event that you are working in a format that mocha doesn’t support, we recommend converting the footage to an image sequence.

If you are just tracking, you can use any compressed format such as a JPG sequence and then use your original footage when you apply the data. If you are going to be doing rendering, such as using Mocha Pro’s remove or insert modules, then we recommend converting to a DPX or TIFF sequence.

Make sure of the following when converting to an image sequence:

  • The frame rate, aspect ratio and dimensions are the same as the original footage.
  • If you are creating proxy footage, make sure the aspect ratio and frame rate are the same.
  • If you are using a particular bit depth, make sure you convert to the same depth if you are using the footage for rendering inside mocha
  • If using compressed footage, don’t set the compression too low, as this will create artifacts that may hinder tracking and roto.
  • Make sure mocha supports the sequence you are converting to!
  • If you would prefer to convert to a movie clip format then we recommend a standard format that QuickTime would understand, such as Animation.
Please let me know if you have any questions and I will be happy to help you.

Hi Mary,

Thanks for the quick response.

The only reason I’m thinking it’s not a codec issue is because I can launch Mocha standalone and the same clip comes in fine.

Even stranger, if I pull in a clip from a different project (same codec as the problem clip) it all works as expected from AE.

The only difference between the 2 is the frame rate and the volume they from.

Did I stump you yet?

:wink:

It still unfortunately could be the codec, the mocha AE package is different from the standalone and it might be a bug that made it into AE and got fixed on our more up to date releases in our standalone. Can you try a PNG or JPEG sequence? If it’s the codec, the JPEG or PNG files will work fine and the movie file won’t.

Cheers,
Mary

Thanks Mary,

You were right about the codec, of course.

And, just for reference, I have it set to launch Mocha Pro 4.1.3 build 10962. Not the AE version.

Thanks again for your speedy response, much appreciated.

Andrew

 

Weird, I will pass that along to our dev team, thanks for letting us know!

 

Cheers,
Mary

Hi Andrew,

Can you show us the full directory path of the footage you’re trying to load?

The first one is the one that works.
The second is not working. Also strange, they were both transcoded the exact same codec, yet one type says MPEG and the other QuickTime.

 

 

\.$DU.factb\Wen4_2\w4_FOOTAGE_2\BROOKE-S_120915\Brooke S Proxies_15Y12M09

 

M:\CBAS\CBAS_proxies

Ah ha!

I just moved same clip to a different directory and it works!

It must be the (-) in the file path because I tried another clip from that volume from a different directory without a (-) and it worked.

I see nothing wrong with the second file path, but there could be an access issue on that path.