After Effects 2020 Registration Issues

  1. I installed the demo, loved the software, and bought a license (After Effects 2020).
  2. Registered and all was great for a few days.
  3. Opened a project, dropped in some chromakey footage, and couldn’t get a HUD in Primatte.
  4. Used built-in chromakey as a last resort and then opened the surrounding composition.
  5. Layers built with BorisFX (snow) had red Xs across them.
  6. I re-registered the software - no HUD no fix for the Xs.
  7. I reset the registration in my account and re-activated my license again. Still no fix.
    It appears that Continuum is stuck in demo mode. I’m not sure the HUD issue is related, but I can’t use any of it.

I’m on a 2015 27-inch iMac.

Hi Dave,

Sounds like everything was at one stage working fine for you but for some reason, the license is failing now and the overlay tools are not showing up. Can you think of anything that may have changed on the system to cause this? OS update maybe?

You might want to uninstall the software and deactivate the license, then reinstall the software and try to reactivate it. I sometimes find that deleting the BCC prefs can help.

If that doesn’t do it then you would be best served by generating a support ticket via the support page on our website.

I hope this helps!
Peter.

Thanks, Peter. A reinstall was going to my next step as nothing changed that I’m aware of unless Adobe auto-installed an After Effects update. And I did generate a ticket so I’ll keep working on my own and wait for a response there. Thanks for replying on a Saturday.

You’re most welcome Dave.

And you might also go to : Macintosh HD/Users/BorisFX/Library/Preferences and delete anything with “com.borisfx.continuum” in the name. These files are rebuilt by the system when you run the application.

Another thing to try is to log in to your account and reset your software key. Or you can wait till Monday and let our support techs guide you through the process, which I’m sure they would be happy to do.

Cheers,
Peter.

Thanks. I tried resetting the software key already. The path to the prefs file is very helpful. I’ll try the prefs first and then a reinstall. If nothing else, that will eliminate some steps when I can get with support. Again, much appreciated.

Adobe Affect effects uses a disk cache to store frames even between sessions. So if you are seeing the Red X’s in frames you would have previewed prior to licensing then it’s likely AE is just serving up those older cached frames to you. Choose AE’s option for Edit->Purge->All Memory & Disk Cache to fully flush any cached watermarked frames. Does that solve the watermarking issue for you? If not then this is something to follow up on with Support.

As for the HUD issue, that is almost certainly unrelated since trial mode should be identical to the licensed version other than watermarks in the renders. I wonder if the HUD pref was accidentally toggled off for you? If you look in the custom buttons in the effect control pane for Primatte Studio - or any BCC effect - you will see one labeled “H.U.D.”. Toggle that button on/off to see if it restores the on-screen overlay widgets for you. The text on that button will be blue when HUD is enabled.

-Jason

The HUD button toggles blue as it should but the HUD panel never appears.

The red Xs were resolved with a reinstall.

Anyway I could jump on the phone or zoom with you to see if I can get through this? I need to produce some content and I’m stuck.

Thanks,

I’m not sure why, but the HUD popped up again long enough for me to make two rectangular “clean background” selections. Now it’s gone again.

And now it’s back for no particular reason. Let’s put this one on hold and I’ll see what happens.

Hi Dave,

Just want to make sure that you realize that the toolbar overlay for Primatte will only appear if the filter is selected in the AE filter control panel. If you deselect the filter, the UI will not be displayed.

Yeah. That wasn’t it. I’m not sure why it disappeared, but I’m pretty tech savvy. I’m doubtful that I missed anything as obvious as that, but you never know. I’m just glad to have it working again. If it stops, I’ll try to keep track of what might have triggered the disappearance.