Applying Film Stocks to Adjustment layers produces a still image at playhead

If apply a BCC+Film Stocks look to an adjustment layer, I end up with a still image derived from the playhead position, while if I apply the effect directly to the clip, the effect works as expected.

I’ve tried rendering the selection, but the issue remains.

What an I missing?

Latest version of Continuum, Premiere 14.9, Mac OS 11.2.1

Is this only when inside the FX Editor UI or does it even affect rendering back in Premiere? We are aware of the problem of a single frame inside the FX Editor UI when applied to adjustment layers in Premiere but are not aware of issues affecting the actual render back in the host. Premiere has long had host bugs regarding their Adjustment Layer handling with plugins and we think this is another such host bug. Perhaps a sub-sequence would provide a workaround?


It’s not just in the editor, it persists in the rendered timeline, and the issue is there in the latest premiere beta as well.

I haven’t used sub-sequences before. I’ll have a look at them.

Hi John,

I tested this and I’m not seeing the single frame for rendered output as well as in the timeline. Can you send me your project to so I can check it out?


Sure. I presume you need source files? I’ll try to make small example.

Hmm…I think this must have something to do with the files I’m getting from my Ninja V. I’ve got it set to give me Apple ProRes 422, and if I transcode an example project to send you the issue goes away, and even if I trim a file with Quicktime the issue disappears.

The example I have that shows the issue is 11 gigs…will that work to email you? Is there a better way to give it to you?

Hi John,

Does the source clip actually matters? If you try it with some sample footage, can you still repro it?

I’m not exactly following. So if you render out the example project the issue goes away? So its only an issue in the timeline?


If I use “File…export” to export the project, the problem persists in the resulting file.

I made an example file using “collect and copy to new location” from the project manager and the issue remained.

But, using “consolidate and transcode”, the resulting new project did not exhibit the issue.

Further, using Quicktime to make a new trimmed file from the source resulted in a file that, when imported into the project, did not exhibit the problem.

However, several clips on the timeline do have the problem, and I see the issue in another project, this one in the latest beta of Premiere.

So, it don’t think the issue is in the project file, but, perhaps, in how Premiere (and Continuum) treat these Ninja V files—just guessing.

If I take an MP4 produced by Premiere, and place it on the timeline, I don’t see any issues, but I do with the Ninja’s MOV files.

Hi John,

I tried using a NinjaV-FX6 ProResRaw video sample clip I downloaded off of google but I’m not seeing this issue in the timeline nor in the export. Can you also send us a sample Ninja mov file that can demonstrate this issue? There are free websites that can send huge files such as . We also use dropbox but I think those free website is better since you don’t need to create an account and the file expires after a set amount of time.

Can you take a picture of your export settings when you do File->Export->Media and send me the settings so I can match it up?

In the meantime to workaround this issue, it might be a good idea for you to just re-encode some of your footage that is having this issue via Media Encoder. Either that or apply it to the footage itself or trim the clip since those steps seems to correct the issue for you.


Thanks for the follow up. I’ll send you a link later today.

Hi Linh:
I just recorded a new, very short, clip to use as an example and—lo and behold—I can’t reproduce the problem. The NInja’s firmware has been updated since the problem files were shot, but I wouldn’t have thought that would matter. I’m thinking we’re not going to make too much progress finding this transient issue.

Anyway, I can use a workaround for the problem footage. Thanks for you help.

Sounds good John! Please let us know if this issue creeps back in.