Auto-Painting after using the clone tool issue

I added this video so that you can understand better what I’m facing. The drag auto-painted well but the clone, bad. Why am I getting this?

It happened the same way on my mac, and I have silhouette 2021.5.6 on it.

Here’s a link to the video:

sorry about the lag. Thanks. It is a slow windows pc

The Clone strokes are not matching because you had Source Match Move enabled when you painted your clone strokes.

When you Match Move in Auto Paint, it is the position of the paint stroke that is match moved. For Clone, you have the additional option to also match move not only the paint stroke, but also the clone source. If Source Match Move is enabled in the Clone controls while painting a stroke, this tells Silhouette to match move the actual clone source when match moving in Auto Paint. This is useful when you have a single frame patch or stabilized clone source that you want to match move. In your example, you do not want Source Match Move enabled since you are painting with Clone > Relative enabled. Clone > Relative paints from each frame in the sequence. The result in your case is that you have an added transformation on your clone source and it does not match.

Anyway, repaint your Clone strokes again with Clone > Source Match Move off and then Auto Paint again.

I just did that still the same problem. It feels like it’s painting the video not a frame. Yes it clones well but when I auto-paint, I can see the paint moving. It feel like I’m painting a video and it’s playing instead of it to be still.

Just to reiterate, wherever I clone, and paint, it match-moves but the paint is not still, it is playing like the video.

Please need help. please

Is your track accurate? Can you let me know your exact workflow so we can find where the disconnect is?

This isn’t about my track. The paint I made with my drag tool auto-painted well with the same track. I don’t know if you watched the video I posted but the clone tool, felt like I cloned a portion of the video., and when I hit play, the part I painted is playing along with the video. It feels like a bug but I could be wrong. Anyway here’s my workflow.

  1. Import the footage
  2. Created a session (roto+paint)
  3. Tracked the wall
  4. Use the clone tool, then painted.
  5. Choose my tracked layer, tick match move and auto-paint.
  6. I tried ticking SOURCE MATCH MOVE to see if it would change but no luck.

Pls in the video I posted, you can also find all that I ticked. Thanks for assisting. I really appreciate

Did you unchecked the ‘relative’ option in the clone tool properties and match-moved? not sure this is the thing you are looking for, but give it a try

OK, watching the video, I think you have a lens warp problem more than a workflow one. Your paint strokes seem to “squish” and that is EITHER the track or it’s pulling from a location that is warping differently than other parts of the plate. This can happen if you’re using clone data from a more lens curved area to a less warped area or vice versa. That’s what it looks like to me.