BCC+ Film Stock FX editor locking up Premiere

In the latest version of Premiere (and the newest beta for that matter), invoking the FX editor to adjust the Film Stock effect causes Premiere to become weirdly unresponsive when I return to my timeline.

I can select menu commands, but controls in the timeline are no longer available. I can’t choose “render selection”, since mouse actions aren’t available. I can render in to out, and that works, but after completion I still don’t regain control.

If I try to quit, the project closes, but Premiere remains open, requiring a force quit.

I can adjust parameters in the effects panel, but selecting film emulations isn’t available there, is i?

I’m using BCC 14.0.3, Premiere 15.2 (but, as I say, the same issue is present in the latest beta).

I’m on an iMac (Retina 5K, 27-inch, 2020), 3.6 GHz 10-Core Intel Core i9, 72 GB, AMD Radeon Pro 5700 XT 16 GB. OS 11.3.1

I tried removing the effect and reapplying, but the problem persisted.

I tried applying the BCC Rain Effect, and in that case a trip to the FX Editor didn’t cause any problems.

I can’t seem to get a crash report—as say, Premiere doesn’t crash, just kind of seizes,

Any ideas?

Hmm…can I, should I, roll back to 14.0.2? Could that be a workaround?

I don’t see 14.0.2 available.

Hi John,

Although the dev teams won’t be able to review this issue until Monday, I have some things I’d like you to try.

(1) When you find the host to be in a semi-hang state, launch the Activity Monitor (you can find that in Utilities) . Then select he CPU tab and in the Process Name column, select Adobe Premiere Pro. It will probably have some red text in there stating app not responding but that doesn’t really matter. Click on the button labelled Sample Process - it’ll look a little different depending on the Mac OS version you’re running. I’ve attached a screenshot to show you where it is on Big Sur. Then click the Save button in the sample window and send that to me.

(2) In Premiere Pro project settings, set the Mercury Transport option to software and relaunch the host to see if this alleviates the hang and instability when reentering the host from the BCC+ FX Editor window.

(3) In the BCC Rain filter, you’re not getting the same hang problem because it’s using a different preset picker, the FX Browser (as opposed to FX Editor), which is one of the big differences between the filters that are labelled BCC and BCC+. The BCC+ filters use the FX Editor, the BCC filters use the FX Browser.

Thanks,
Peter.

Thanks for the quick response.

Okay, changing the Mercury Transport option and relaunching doesn’t seem to help.

Sample of Adobe Premiere Pro 2021.zip (72.5 KB)

Just to let you know, I stepped back a minor version to Premiere 15,1, and the issue remains. I didn’t try Premiere 14, since v15 projects won’t open in v14.

Thanks for the update on this issue John and also thank you for providing the process sample - I’ll pass that along to engineering and ask them to take a look into this asap.

Thanks,
Peter.

Hi, John

A few more questions:
-Is this something that worked for you in the past and then stopped working or has it always been this way for you?
-When you’re coming back from the FX Editor, how are you closing it. Via the Apply button or the Cancel button or another method.
-Can you confirm that the FX Editor closes (visibly disappears) or does it also still remain open?

Cheers,
Jason

Yes I worked for me in the past, but here’s what’s changed:

  • I was on an older system and ran into some severe system issues so I have migrated to a new computer (specs in first post). Old system was a late 2015 iMac, so still Mac with Intel.
  • Old system was on OS 11.2, I think, not 11.3.1
  • I was using the last version of Continuum (14.0.2, i think) , not 14.0.3.

I’m closing with the apply button.
The editor disappears…Premiere looks normal.

Hi John,

Can you send me your project? If possible can you send it to linh@borisfx.com

Thanks,
Linh

Sent. Just the project, right? Not the source files?

Okay, I didn’t think of that…I just made a very small new project and I does not exhibit the problem.

I tried on another project and it’s okay too. Hmm…I guess it’s an issue with that project…
and it’s even working on an adjustment layer (which it didn’t do before)!

I tried opening the project that you sent me but it just hangs on “Locating media”. It is kind of weird usually it’d just say media not found but not sure why I can’t open this file.

Are you able to repro this with another project that has the same source? Do you know what is the project settings? Also what about the source setting.

Thanks,
Linh

Hi linh:
Crossposting.
I just tried a new project with a bit of the same source and the issue is gone. The sources were 2 phone videos, both h264, one at 30fps, the other at “30.01” (?)
What project settings would you like to know?

It’s a 2 minute dance and won’t be too hard to build again,

Hi John,

I tried working with the project you sent and I still can’t repro the issue. So it really seems to be isolated to just that particular project on that system for some reason. If it’s still available to you, can you tell us if the same project causes issues on the old system that you were using?

Thanks,
Peter.

Old system is malfunctioning big time—it lost the ability to access any external drive (even a disk image!) After a week of struggling I moved to a new system, Maybe some residual issue from that mess?

Maybe this isn’t worth pursuing further.

Hi John,

I can repro this with a “30.01” clip that I created. Maybe it is the odd fps that is creating the issue. Anywho I’ve filed a ticket for this and the engineers can take a look at it. For now, if you run into this issue again I’d suggest retiming the source to 30fps or something.

Thanks,
Linh

Okay. Thanks for this…I didn’t notice that 30.01 spec. (Why, oh why?)

I’ll watch out for that.

Great support, BTW!