BCC Make Alpha Key, with BCC Gaussian Blur

I am applying part of a video layer onto another with BCC Make Alpha Key (made with a Mocha mask). I also want to blur part of that same clip; however, when I add a BCC Gaussian Blur to the Effects, it seems to just turn off the Alpha Key completely, and I don’t see either effect.
I thought I had used other effects in combination with Alpha Key before, but this time I can’t seem to get it to work.
Advice? Thanks :slight_smile:

You forgot to mention the host and platform that you’re working with … I just tried it in After Effects on Mac OS and it’s working as expected. What host / platform are you using?

I’m working on Windows 11.

Great - the host information is also important - which host are you using?

1 Like

I’m sorry, I didn’t realize what you meant.
I’m running in Adobe Premier.
You’re right, I fully expect this work, but it is not on this clip. I’m going to also set up an experiment with this same footage in a test project & see if it still has any issues.

Thanks for that - I’ll give it a shot in Premiere to see if it’s working as expected on my system. Could indeed be a problem with just a particular source clip, as you mention - after you test with a different source clip, please let us know your findings and whether it’s the clip or the software that is the problem on your system.

I have reproduced this in a simple stand-alone project, using the same video clips. There are 2 layers in Premier.
I apply BCC Make Alpha Key to the top layer, to bring in just part of it, overlayed on the bottom layer. I used Mocha to create my Mask (no tracking, just drew a quick spline). I feathered it by 12. I set the Alpha From Channel to “Full On”. At this point, I can see the section of the top video that I have masked appear in the preview window, overlayed on the bottom video.
Now I add BCC Gaussian Blur to that top layer; and it seems to “shut off” the alpha key. I don’t see either a blur, or the alpha key; I only see the bottom video layer. If I toggle either one off, the other one shows up. So if I turn off the blur effect, the alpha key appears; if I turn off the alpha key, but turn on the blur, the blur appears (the entire top layer appears in the video, blurred). But if both are on, neither seems to apply.
These are the only settings I’ve changed from the effect defaults.
Are you able to repro this at your end?

Thank you for providing all of the steps and system info - with that, I have successfully repro’d the issue as described. It’s platform dependant - windows only - which is why I failed to repro the first time I tried as I was using a Mac, which does not have this issue. I’ll file a ticket against this issue for engineering to work on. And thank you for bringing this to my attention.

A workaround for the issue is to make a subsequence out of the clip with the Make Alpha filter and then pull the subsequence into the timeline as a replacement for the original source. Then you can apply the Gaussian Blur filter on top of the subsequence to achieve the desired result. And to avoid blurring the edges of the subsequence alpha, set the Gaussian BLur to RGB instead of RGBA.

Cheers,
Peter.

Hi, i know this is a totally different program but i had a play with this so just for your info i thought i’d share, it seems to work ok here in Vegas Windows 10,
I adjusted the Alpha Offset to show the Alpha is still working


Good to know - thanks for that Gid! Seems like the issue is isolated to Premiere Pro on Windows. I’ve filed a ticket with engineering.

1 Like