Bcc Motion Blur and Vegas


#1

Hi Everyone, for the life of me I can’t work how to select source layer of this plug when using Vegas. I just want to use the source layer and not the Fg layer - I select source on the source layer but I get a black frame and then a frame of the animation…I know that I’m supposed to be able to select the media or am I missing something? Does the Fx actually work in Vegas?

Thanks In Advance


#2

Vegas does not have good host support for choosing alternate layers. Normal Track or Event effects do not have access to secondary layers so there is no way to actually choose a different layer to drive effect properties. Some Continuum effects are offered as Custom Compositing Mode effects in Vegas which does give them access to an alternate layer - but Vegas then applies this effect to the entire track so it must be typically moved into a subsequence. Unfortunately Continuum Motion Blur is not offered as a Custom Composting Mode at this time so it doesn’t have this workaround. I will file a feature request to have this effect added to the list of Custom Compositing Mode options in Vegas.


#3

Thanks, but I’m still a little confused - so does the plug work in Vegas? And can I drive the effect by putting it as either a track effect, media effect or video fx, and if so how? Sorry, I may have not explained myself in the last post properly…I’m still learning the language of these effects.

The manual isn’t very clear - I understand that Vegas is a small player in the editing industry…although it shouldn’t because you can do everything in the one program…I come from an audio background and love that Vegas works like a DAW.

Thanks again.


#4

The plugin does work in Vegas but it can only be used where the motion information is coming from the same clip the effect is applied to. I.e. the clip you apply it to will itself drive the amount of motion blur. That is not always what is desired, but that is still a useful result in many cases for artificially augmenting the amount of motion blur in a clip, and it is the only option supported in Vegas at this time. If you are wanting to drive motion blur in one clip based on motion in a different clip then unfortunately that is not supported at this time in Vegas, although we’ve logged this in our list of potential future enhancements.


#5

Sorry, yes it does work - although it still is confusing. I suppose I like to be in complete control of said effect. From what I’ve ascertained you’ve got to select source on both the source layer and fg layer to make the effect work? That’s correct yes?

And absolutely the effect is very useful - I’ve recently branched out into 3d animation using Blender as my animation program and Vegas for compositing and effects. I found that Hitfilm Ignite can sometimes be a bit hit and miss - even though I understand the shutter angle formula, and hence I brought the Boris motion blur. I like Hitfilm for longer pauses in between movement, and Boris Motion Blur for more fast movement.

Got to say, I love Sapphire Lighting too - I will be buying more of these effects for my work in the future…what I don’t think most animators get is, you can cut render times down and add in things like volumetric lighting in post-production.

Thanks Again


#6

I would recommend ignoring the FG Mask layer and controls for most situations and concentrate on dialing in the motion blur using the main Motion Blur controls at the top of the effect. If you want to mask out certain regions of the image so they are not blurred, the easiest approach is to use the PixelChooser controls at the bottom as opposed to the FG Mask controls. Also, when using the BCC Motion Blur effect be sure to compare results when switching the Optical Flow Method to Advanced and Optical Flow Resolution to Best. Depending on the details of the footage and whether or not your GPU can handle the Advanced mode, you may get more accurate motion estimation in the Advanced mode, although it can take longer to render at some settings.


#7

But this doesn’t work - when I only use the source layer and select source…I get a black frame output and then an image frame output…I hope that makes sense. The only time I get the plug to work is by selecting both source and fg layer.

Thanks.


#8

I’m not able to reproduce what you describe - using Vegas 16. When I apply Motion Blur by default in Vegas the main Source Layer is already set to Source and the FG Mask Layer is set to None. I don’t need to change either of those to see the motion blur results - just crank up the Motion Blur Amt to make it more prominent. In fact if I set FG Mask Layer to Source then all blur disappears unless I then crank up the FG Motion Blur Amt. I see this in both Continuum 11.0.3 and in the newly shipping Continuum 2019. If this doesn’t match what you’re seeing could you please send us a project file (without media should be fine) so we can analyze your setup. Also please include exactly which version of Continuum and Vegas you are using. If you want to send it off list you could email it directly to me at jclement at borisfx dot com.


#9

I have the Plugin Too But the Unit I purchased Purchased with a year of Continuum 2019 the Installer says for me to upgrade .I am saving for 2019 .Is the Installer and Activation Tool the same iv V12 as 11 ?If so it is still not removing unite that are unlicensed and is hanging also.I own Both Mocha 2019 as well What would you suggest?

I purchased Direct from Sales over the PHone. Motion Blur.


#10

Hi Jason, I tried to send you an email on Saturday…and I’ve just been told that your server won’t accept it. I’m using one of my uni accounts too…so not a dodgy one. I’m attemting to send same email this time from my other uni email account which is a UON account from The University of Newcastle here in Oz.

Sorry Ben


#11

Hi, Ben,

With the project you sent off-list we are now able to reproduce the problem you describe with black frames. We’ve filed this in our defect database and will get to the bottom of it. Thanks for reporting!

Cheers,
Jason