BCC Primatte Studio in Resolve B input for Light Wrap?

I noticed today that when I select background input on the light wrap option I don’t get the error saying this is not supported.

So wondering if it is supported now. And if so how do I pipe say the background element into the light wrap function ? When i Drag the still into the node tree in comes in as a matte.

thx

Hi Chad,

One possible route for you would be to do the keying in the Fusion tab where it’s easy to add a second input to BCC Primatte Studio. Fusion is not 100% supported by Continuum but this should work for you.

If you need tips on the workflow for that please let me know.

Cheers,
Peter.

There is a workflow here in the BCC docs on secondary inputs in the Resolve Color pane, although it’s for an older version of Resolve so the details may have changed a bit:

Hi Peter

Any pointers you can offer on Fusion workflow would be great. I have tried using it a few times but usually get frustrated and just go back to After Effects to do what I need.

thx

I will take a look thanks!

No problem - I’ll write out the steps that you’ll need to follow to make it work in Fusion.

1 Like

(1) stack the key source on top of the background source in the resolve timeline

(2) go to the fusion tab

  • you’ll see 2 nodes : MediaIn1 which is the foreground and MediaOut1 which is the output

(3) add primatte studio to the fusion node tree

  • you can right+click in the node tree and then select add tool>bcc key&blend>primatte studio
  • this will add the disconnected primatte studio node to the node view

(4) grab the arrow on the output of the MediaIn1 node to disconnect it from the MediaOut1 node and connect that to the PrimatteStudio1 node input

  • this is the input on the left of the PrimatteStudio node

(5) grab the arrow on the PrimatteStudio output and connect that to the MediaOut source

  • this is the input on the left of the MediaOut node

(6) at the bottom left of every node there are two black dots with each dot representing a viewer output

  • clicking on the dot on the left displays the output from that node to the left viewer, and the dot on the right outputs the view from that node to the right viewer
  • set the output of primatte to the right viewer

(7) use the primatte tools from the control panel to create a good key

(8) add a background source to the tree

  • you can right+click in the node tree and then select add tool>I/O>loader
  • then select the clip to load up as the background for the composite

(9) drag the output arrow for the background and connect it to the PrimatteStudio source 2 input

  • this is the input on the top of the primatte node

(10) in the primatte studio controls, enable light wrap edge

(11) in the primatte studio controls, set the background to source B

(12) you should now see the foreground composited over the background and you’ll have full control over the light wrap of the background over the edges of the foreground

  • I’ve attached a screenshot to show the node tree that you need to create to produce this result

TREE

Hi J

I tried out the workflow in the doc you linked to. I was able to bring in the background element as a matte and plug it into the B side of Primatte node by right clicking on the node and selecting add OFX input. The piped the BG node into the B side. I was able to confirm that this was working by tinting the BG and seeing that reflected in the Resolve output.

However the results were not what I was hoping for. Having a darker light wrap over darker portions of the BG and lighter wrap values to match the lighter values of the BG.

Better than it was but still not quite there.

Will give this a go. Thanks Peter!

You may need to make adjustments to the Primatte settings in the Light Wrap Edge grouping to produce the result you have in mind. Try working with the Lightness parameter, perhaps select a different Apply Mode and use the Mix with Original to get a more natural looking composite.

When I bring the BG layer into Fusion it makes the image much lighter. By like 2 stops. When I apply a color correct node before feeding into PM the adjustments are very course. The blacks get crushed right away. I am finding this also adds noise to the fill side. So the interviewee white jacket is getting quantized looking. Also the performance is very slow. Even on the MacPro, SSD Raid 125 gigs ram and 6900XT card.

What does the result look like when you set Primatte to display the matte status?

Here is a screen shot of the matte status in Fusion.

I went back to using the B input in the color page as Fusion performance is very slow. Now when I try and render in the color page I get 2 frames of the comp then 2 frames with the greenscreen as if no key was applied. Then render then goes back and fourth between keying and not keyed.

That matte looks good alright. I’ll set up again on my system and render to disc to check the result. What platform / version are you on?

So I just rendered and it worked as expected on my system - no problems. Did you follow my instructions per my note above? I think you may have a slightly different setup. If indeed your set up was in any way different to mine can you please try again but following my steps to see if that works?