BCC Title Studio - busy cursor and "not responding" all the time

Hi everyone, I am having difficulties with using BCC Title Studio and am hoping there is a workaround or patch that can help.

When I select the ‘Curtain Red’ preset (or any preset), and click ‘Launch UI Window’, I get the spinning cursor and then when I click on my editor’s window it changes to ‘Not Responding’, then I have to click ‘Close Program’.

Another scenario, if I just click on the ‘FX Browser’ button I get the same result.

The only way I can open BCC Title Studio is if the preset is ‘No Preset’ and I click on ‘Launch UI Window’. In this scenario, the window opens and I can use the tool for a while but sooner or later it will fail just like the other scenarios.

I am using Sony Vegas 15 and BCC Title Studio 9.1400 as part of a Continuum 2021 14 OFX subscription.

I opened a case 3 days ago with BorisFX but there has been no response.

Can anyone help?

Regards,
Andrew.

Hi Andrew,
I have VP18 and tried what you posted above, and was able to launch the UI Window with no problem as seen in the screenshot below. I can also launch into FX Browser.

Hi, Andrew,

Since Title Studio is GPU based, the first thing to try would be updating your GPU driver. Also please include detailed system specs.

Cheers,
Jason

Many thanks for trying my test case. I have found that the program crashes if the Vegas playback indicator is inside the clip I am editing and the preview window is showing the output of BCC Title Studio. If I move the playback indicator to some other clip that does not contain BCC Title Studio then I find I can launch the UI Window and view the FX Browser.

Having said that, I have been using the above workaround to create my project but now that I am almost finished I am finding that things have taken a turn for the worse. For every clip which contains BCC Title Studio as soon as I click on ‘Launch UI Window’ the program crashes. An hour ago this project was usable and I could edit the BCC Title Studio clips but now they all crash.

I will try to create a new project and re-import the clips and hope the same doesn’t happen again.

Hi Jason,

Many thanks for the reply. I am using an NVIDIA GeForce GTX 750 Ti, driver date 24/07/2019, Driver Version: 26.21.14.3200.

The system specs are:

System Information report written at: 12/05/20 19:01:36
System Name: NZXT
[System Summary]

Item Value
OS Name Microsoft Windows 10 Pro
Version 10.0.18363 Build 18363
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name NZXT
System Manufacturer ASUS
System Model All Series
System Type x64-based PC
System SKU All
Processor Intel® Core™ i7-4790K CPU @ 4.00GHz, 4001 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 0330, 29/05/2014
SMBIOS Version 2.8
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product Z97-K
BaseBoard Version Rev X.0x
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume4
Locale United Kingdom
Hardware Abstraction Layer Version = “10.0.18362.752”
Username NZXT\Andrew
Time Zone GMT Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 6.85 GB
Total Virtual Memory 47.2 GB
Available Virtual Memory 35.1 GB
Page File Space 31.3 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualisation-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and the device is not Modern Standby, Un-allowed DMA-capable bus/device(s) detected, Disabled by policy, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualisation Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

Hi Jason,

I have upgraded the NVIDIA drivers to 22/11/2020, version 27.21.14.5751. It hasn’t changed anything.

To reproduce a BCC Title Studio crash I just do the following:

  1. Launch Vegas
  2. Drag the Horizon Media Generator onto the timeline
  3. Click the clip, and select ‘Media FX…’ from the context menu
  4. From the Plug-in chooser select BCC Title Studio, click ‘Add’ and ‘OK’
  5. In the ‘Media FX’ dialog, under ‘BCC Title Studio’ click ‘Launch UI Window’
  6. ‘VEGAS Pro has stopped working’ dialog appears

It’s really puzzling how I’ve gone from been able to partially use the product, to being completely unable to use it.

I have ‘upgraded’ to Vegas 18 and the same problem exists. In addition my project which I created on version 15 now doesn’t play correctly on 18. I’m really losing faith in Vegas and BorisFX.

The reason my Vegas 15 project won’t play on Vegas 18 is because MAGIX have broken the GPU acceleration. With the GPU acceleration on the video playback plays random frames from all over the timeline, inserts blanks frames of solid green or gets stuck and keeps playing the same 3 or 4 frames over and over again.

When I turn off the GPU acceleration I can play my Vegas 15 project in Vegas 18.

I still had issues with BCC Title Studio. It didn’t matter if I use Vegas 15 or 18, with GPU acceleration on or off, as soon as I click on ‘Launch UI Window’ the editor crashes.

I have de-installed and re-install Continuum 2021 and will see if that changes anything.

@andrew2, I am not sure about that, but I could be wrong. If that were the case, many others would be posting the same problems.
I started with VP14, and upgraded to 15, 16, 17, and now 18 and not a problem with GPU acceleration. But then I am using an “old” AMD graphics card. I have read of people with Nvidia have problems and the recommendation usually is to use the Studio drivers.

In addition to the studio drivers, you may want to give a driver cleaning a try. I seem to need this maybe once a year on my main laptop depending on what kind of shenanigans I go through with drivers throughout the year.

The first time I used this, it made a major improvement in VP stability.

Hi, Andrew,

Can you please gather some log information that we can analyze?

  1. The BCC.log file found here:
    C:\Users\YOUR_USER_NAME\AppData\Roaming\BorisFX\Logs\BCC.log

  2. The Vegas crash dump(s). To access these please do the following:
    Go through the process of getting Vegas to crash. Then Vegas will typically pop up the Vegas Problem Reporting Service crash dialog. When that dialog pops up hold Ctrl+Shift when clicking the “Send” button and it will point you to the ZIP file of the crash dump. Grab that zip file an any other recent ones in the same location.

The send all those files to me off-list. You can email me directly at:
jclement at borisfx dot com

After doing that you can try resetting the workspace and preferences files on your machine to see if they became corrupted.

Clear Title Studio Workspace:
-Navigate to (On windows):
C:\ProgramData\BorisFX\ContinuumOFX\14\Workspaces
-Look for any files with recently changed timestamps - e.g. BCCTitleStudioWindowPreferences.tsws
-Set any such files with recent timestamps aside - e.g. on the desktop.
-Restart the host and retest
-If this helps, please send in the corrupted files for analysis.

Clear Title Studio Prefs:
-Navigate to:
C:\Users\jason\AppData\Local\BorisFX\Continuum 2021
-Set aside the file called Continuum14_BCC_Preferences_OFX.xml - e.g. move to the desktop
-Restart the host and retest
-If this helps, please send in the corrupted files for analysis.

Cheers,
Jason