BCC Title Studio not showing lights in OFX Host (Vegas20).. help?!

I’m having a problem with BCC Title Studio OFX Host (Vegas 20).

Using some of the template things look perfect in the Boris UI WIndow but back in the OFX host it’s as if the comp lights are being completely ignored. I’ve created a short video to demonstrate… need for a project deliverable tomorrow… help?!!

Hi Rob,

I’ve not been able to reproduce the issue that you’re showing but I’ll ask our QA team to take a look. In the meantime, can you try using some live action shots instead of vegas solid color generators and let us know if this changes the result?


Similar lighting issue using Type-On Text.

Here’s the Continuum UI – you see the white text clearly (curious, I can’t see any controls in this UI to set text color).

Here’s what it looks like in Vegas preview screen:

Moving light source changed shadow but didn’t get my text to light up any better.

As requested, I tried adding the FX to a video clip as the only FX on the clip, with composite apply-mode changed to “Normal” (tried lighten too).

It’s not showing the full opacity of the Title Studio image. Here you can see what title studio shows, and what’s in my preview window.

Hi Rob,

So no visible change to the result when working with live action shots instead of Vegas generated solid media elements. And unfortunately I am unable to reproduce what you’re seeing. You’re using the most recent version of Continuum Title Studio, right? It should be Continuum 2023.

Do you have any other OFX hosts installed on that system that you can test with to see if the issue is Vegas specific? BlackMagic DaVinci Resolve, perhaps? If not it’s a free download so I wonder if you can try that please.


I have older versions of Vegas (e.g. V18) I can try it on, but no other NLEs installed and no time to dink around with figuring them out today since my deadline is tonight.

Yes – upgraded to latest Continuum version yesterday before posting, hoping that’d address it.


Thanks for confirming the Continuum version. Please let us know if Vegas 18 is producing the correct result.

Same result in Vegas 18. I also tried disabling the use of GPU in Vegas but no difference. Going to change Radeon RX470 driver next, but after that need to move on… :frowning:

Thanks for letting us know, Rob. I’ve asked our in house Vegas expert, Vin, to work directly with you on this.

Thank you Peter. I rolled back my RX470 driver to the “recommended” studio version and no difference.

Hi Rob,

I’m sorry see you’re having difficulty with Title Studio. I took a look at the presets you’re using and they all use the same basic structure, flat textures, so there isn’t anything intrinsically different between them which should cause the issue you’re seeing.

While I’m unable to reproduce the lighting/opacity issue that you’re seeing with the base preset, there are a few things we can try. You may have already done this, but just to be thorough, could you please check to make sure you’re using the latest Vegas20 build (326).

secondly, lets delete all of our preferences and plugin cache.
You’ll want to clear the vegas plugin cache (let me know if you need a walkthrough on that), as well as deleting the Title Studio Preferences.
They can be found here: C:\Users\qa\AppData\Local\BorisFX\Continuum 2023.5 (or the version of continuum you have) \Continuum16_BCC_Preferences_OFX.html

Once you have done that, ad cleared your plugin cache, relauch and see if the issue is still present.

If it is still present, go ahead and reset your Vegas 20 preferences to default and try again.

If it’s STILL rendering incorrectly, save the title animation out of Title Studio (as a .blu file) and send it to me. Perhaps there is something in Title Studio that got toggled and isn’t responding to prefs.

Vin Morreale

1 Like

I think I found the magic button.

In Continuum Title Studio, “Controls” tab, as I progressively lower “Final Quality Level” from Best to “Basic”, the image in the Vegas host becomes progressively brighter. When set to “Basic” it looks 100% proper.

??? Does this help you figure out what’s happening?

Hi, this is mine, I haven’t changed it so I’m presuming that it is the default, changing Basic down to Best makes no noticeable change, I don’t think you’ve found the reason just yet :thinking:

Are you using V20 as your NLE, latest build?

I could literally watch it progressively get brighter –
in V20, preview of TS was dark-grey. Went into TS and lowered FinalQualityLevel <save/exit>
in V20, preview got a bit brighter and more saturated! Repeated process in TS…
V20 was full saturation/brightnes only when Final Quality Level was set to “Basic”.

I’ll make a video demonstrating.

It may (or may not) be the root cause, but it absolutely fixed the problem.

Yep VP20 build 326,
TS plays like crap on my machine, so I might have something setup differently to you,
FX browser also plays like crap,
I tried recreating your problem earlier when you first posted but couldn’t,
If you want me to set both programs up in a certain way just let me know,

I took a look at the render quality setting and was unable to reproduce any changes in the overall opacity/composite. Did clearing the preferences help at all?

one of my TS titles worked OK… the other had the issue we’re talking about here… so it seems maybe specific to a template or something it’s using in it?

  • The Depth-of-Field templates (FX Browser) worked OK.
  • The ones in LogoReveal and MotionTitles (I think) had issue.

Here’s a video showing the problem and how it’s getting fixed …