BCC Title Studio - Procedural Tutorial

Greetings,
Is there any tutorial or instructions available for how to apply the Procedural or Gradient in BCC Title Studio. I’ve added it from the media selector, but not sure how to get any visible results with Procedural or Gradient chosen. Thanks for any help!

This is the only video I see showing the Procedural, but I couldn’t find anything on how to use it.

Procedural media textures are accessed either as a media type on a track shape or via the Texture Composite shader. So for the latter, apply the Texture Composite shader to an object, then select Procedural as the media type.

I was able to get the Procedural to work/adjust when applying it from the Media type drop down, but when I apply a Polished Metal Material, and try to add a Procedural via the Texture Composite Shader, I’m not seeing the Procedural show up. Could you please let me know if there is a specific item I need to be clicked on in the Container tree before applying the Composite Shader, or is something else I need to do? Thanks!

If you would like to send me your Title Studio project I would be happy to take a look - it sounds like it could be a compositing issue, ie, you might need to set a blending/apply mode to the texture shader.

Hi Peter, much appreciated! For reference, the material I added was Palentir from the Polished Metal group. And there’s the Procedural I tried to add in, but it’s only visible in the Layer tree, I don’t see it doing anything in the Model window. Thanks for looking into it!
procedural test project.blu.zip (2.3 KB)

Thanks for the project - I spent a bit of time working with it but was also encountering issues. I’ll discuss it with the engineer that work on this part of the code.

Ok no prob thanks Peter! Ultimately I was trying to use the Palentir Material preset and just add a Procedural on top of it, to blend in if possible. Thanks again.

Ok, I figured it out myself - the problem is that there is a switch at the very bottom of the control panel for the shader that is labelled “UVW mapping” and this is enabled by default but if you disable this option you’ll see the result that you were expecting. You’ll have to stretch out the panel in order to find the UVW mapping checkbox. The UVW mapping is there to avoid any visible seams when wrapping a 3D object such as a sphere, where it would be most objectionable.

Cheers,
Peter.

Ah ok, thanks. Yes I see unchecking the box UVW immediately shows visual feeback of the Procedural. I tried moving the Texture Composite upward in the tree and I noticed that the Procedural visually disappeared again, but then I had stumble onto a page in the online manual talking about changing to 2D composite
Page reference: https://web.borisfx.com/helpdocs/?page_id=8354


and then all of a sudden the Procedural shows up again, it does look a bit different the way it blends, but why is it that having the Procedural down in materials shows up in both 2D composite and 3D composite, but if I move the Procedural upward, I need to be in 2D composite? Thanks again.

This image is when applied at material level with UVW unchecked

This image is when applied up higher in the tree, but needed to switch to 2D composite

Additional question: Is there some setting I need to change to have the beveled edge not look like the have a seem line? The screenshots were taken with preview quality set to the high setting, but the transition from flat front face to the bevel curve looks noticeable to be when zoomed in. Thanks for your help!