BCC+ Vignette rendering bug w VP 19

Continuum 2021.5 14.5.2.389
Vegas Pro 19-341

Apply BCC+Vignette fx to a jpeg image event.
Rather than being applied to the event, the vignette affects the entire track.
What I expected was a faster version of BCCVignette which is applied to the event exclusively.

BCC+V

BCCV

Project and assets
BCCVig.zip (2.7 MB)

Sorry, I can’t repro this. I’m getting a Vig on the Event.

@biggrazie what do you get when you open the project I attached?

I was attempting to follow your on screen instructions rather than using your ZIP. I’d prefer to hear from you and see your description as this would inform me as to what you are doing. Often Users interpret what they are doing as to how they achieve outcomes. I wanted to know about your “how” and not the “outcome”. A step by step approach. Yeah, it’s tricky stuff this. Maybe an instructional video showing me your steps would help me?

@michaelh … I DLd your project and got the same result in VP19 (b341) as you have shown above (also using BCC 2021.5).

However, in BCC+Vignette if you change the ‘GPU Rendering’ field to Disabled, the vignette reduces to the primary image only, The height of the vignette doesn’t alter, but the width contracts from the full frame width down to the width of the primary image.

Curious, heh?

@biggrazie simply open VP, new project, drag the image onto the timeline, create a solid color white event on the track below, add BCC+Vig to the image and you should have a vignette that follows the edges of the window rather than the image.

@dexcon can confirm, turning off gpu rendering results in the vignette following the edges of the image, at least horizontally. If I use pan/crop to change the size, the vignette doesn’t follow. Regular BCC Vignette does.

One thing I’ve noticed is that even though I’ve told windows to use the nvidia gpu for VP, the intel gpu is the one that’s primarily being used when rendering. The nvidia gpu is selected in VP options.

GPU 0

Intel(R) HD Graphics 630

Driver version:	30.0.100.9805
Driver date:	7/23/2021
DirectX version:	12 (FL 12.1)
Physical location:	PCI bus 0, device 2, function 0

Utilization	3%
Dedicated GPU memory	
Shared GPU memory	0.9/7.9 GB
GPU Memory	0.9/7.9 GB

GPU 1

NVIDIA GeForce GTX 1050

Driver version:	30.0.14.7141
Driver date:	7/12/2021
DirectX version:	12 (FL 12.1)
Physical location:	PCI bus 1, device 0, function 0

Utilization	0%
Dedicated GPU memory	1.6/2.0 GB
Shared GPU memory	0.6/7.9 GB
GPU Memory	2.3/9.9 GB

@michaelh
Which gpu do you use for video processing. Here it renders correctly if Intel is used for video processing in Vegas but I get the same results as you when nvidia is used.

But it might be Vegas bug as it works correctly in Vegas 18.

@misohoza as above, nvidia. If I select intel using the windows settings the effect just whites out the output as in

Thanks for that check. Yeah, it works fine in 18 but not 19

Well, I was referring to the gpu acceleration of video processing in Vegas preferences.

I also run Vegas itself with nvidia but sometimes switch the video processing between intel and nvidia.
I also got this completely white image at first but then it worked (with intel).

@misohoza for me, when I switch to Intel in the options it stays white except during the transitions.

This is what I get when running your project:

Intel HD 620

Nvidia GeForce 940MX

@misohoza If I run with 17 using Intel, it works as expected. 18 and 19 white out as I showed.

Hey Guys,

I’ll ask our QA team to review this BCC Vignette issue. If you disable the GPU option in the BCC+Vignette via the GPU Rendering pop-up are you still seeing the problem? And is the issue present when only working with a solid white event media generator or does it happen with actual video source shots?

Thanks,
Peter.

@PeterMcAuley If I disable gpu in the BCC+Vig panel it works the same as the BCC_Vig effect. The Vignette is only around the image itself.

The issue is present on stills (though I’d expect on video as well) that is smaller than the project dimensions.

I was working on getting some more testing done and writing this up on the vegas forum too but have had too little time today.

A couple of new data points.

  1. Both my machines have dual GPUs. One intel and one Nvidia. It doesn’t matter if the Intel is disabled at the bios level. So it’s not an interaction between the two GPUs.
  2. If Nvidia is selected in Vegas, the problem happens unless gpu is disabled in the prefs for the fx.
  3. If Intel is selected in Vegas, the fx works as expected. I have had one case, mentioned above where selecting Intel resulted in an inverted white-out behavior. I have not been able to reproduce this after a reboot.
  4. I have not been able to reproduce any of the problems on either of my machines using Resolve.

GPU ON and I’m using a GREEN BG. Which one of these do you wish to achieve?:
Sample 1

Sample 2

Sample 3

Sample 4

@biggrazie imo you’re confusing things by moving the fx around. That wasn’t part of the steps I gave you :slight_smile:
For @PeterMcAuley too…

What I’m looking for is the BCC+ fx to behave the same as the BCC Vignette. By default the fx is placed in the chain after pan/crop and the old fx is only applied to the edges of the event it’s placed on.

When Nvidia is chosen as the default gpu in VP Preferences|Video, BCC+Vig is applied to the entire window.

If one has an intel GPU you can work around this by choosing intel in Preferences|Video.

One can also work around the issue by moving the fx before pan/crop or turning off gpu use in the fx panel.

@PeterMcAuley is logging enabled for the BCC+ fx?

Well, that wasn’t my intention. I did not understand your steps so I rather went for asking you directly, which of the four samples I put together you wished to achieve. I was hoping you’d select the one you were after, but obviously my approach failed.

@biggrazie What GPU hardware and driver version(s) are you using?
Also what version of Continuum?

Having both fx enabled at the same time confuses the results a bit but it would appear that your BCC_Vig fx affects the entire window unless you move it before pan/crop. Is that correct?

@michaelh

Hi Michael, Yep, the BCC+ filters should indeed be contributing to the BCC log file. To find it, simply apply one of the legacy BCC filters then click on the cog wheel to being up the prefs dialog and click on the log button.

And so that I am clear on your request, your preference is that the BCC+ filters should only look to the dimensions (alpha bounds) of the filtered clip just as the BCC filters do, meaning that they should ignore the project dimensions. Is this correct? I wonder if this should be a user defined preference - could be something as simple as an avoid clipping checkbox in the filter UI. That’s if the API supports such a feature - I know AE does so I’d have to consult with engineering to see if it’s possible in OFX hosts.

1 - EVGA RTX 3080 XC3 Ultra 10GB - Driver 471.68
2 - Continuum 2021.5

Here are BOTH before and their results. Notice I have turned each OFF in turn. Now, which of these are you trying to achieve?:
Sample 1


Sample 2