Black screen after importing

RE: mocha for After Effects v2.2.1 / build 2932
MacPro / OS X 10.6.8 / QuickTime 7.7.6
When I import a movie (.mp4 file), I frequently get just a black screen. The time line “plays”, and indicates the correct number of frames, but there is no video. I have searched this forum, and it appears that others had experienced this problem, but may have been fixed.
I also notice that when I first launch mocha for AE, the typical “active application” icon appears on the right hand side of the Mac OS X dock panel. However, after I start a new project, as soon as I load a video file, there are TWO icons in the OS X dock. Both icons are identical, and they both appear when I use the Mac keyboard shortcut (CMD + TAB) for switching between apps. Is there a preference file, or something in the library that may have become corrupt? BTW, I only have one version of mocha installed on my machine.
I am stuck until I can get the first issue sorted out. Any help with either would be most appreciated.

RE: mocha for After Effects v2.2.1 / build 2932
MacPro / OS X 10.6.8 / QuickTime 7.7.6

When I import a movie (.mp4 file), I frequently get just a black screen. The time line “plays”, and indicates the correct number of frames, but there is no video. I have searched this forum, and it appears that others had experienced this problem, but may have been fixed.

I also notice that when I first launch mocha for AE, the typical “active application” icon appears on the right hand side of the Mac OS X dock panel. However, after I start a new project, as soon as I load a video file, there are TWO icons in the OS X dock. Both icons are identical, and they both appear when I use the Mac keyboard shortcut (CMD + TAB) for switching between apps. Is there a preference file, or something in the library that may have become corrupt? BTW, I only have one version of mocha installed on my machine.

I am stuck until I can get the first issue sorted out. Any help with either would be most appreciated.

Mary - Thanks for your response. I will try your suggestion and post my results.

BTW, I am using a Mac, and video drivers are part of the OS X operating system. Thus, they can’t be “updated” per se. I have run the Apple Software Update to see if my system and QuickTime are current, and they are.

Update:

? Reinstalled After Effects, and mocha was reinstalled with it. Still won’t import .mp4 files.
? Reinstalled QuickTime v7.7., but no improvement
? Downloaded a demo version of mocha Pro (a different version that what ships with After Effects). This app was able to create a preview of .mp4 files, but the time line in mocha Pro only shows the first frame; no playback.

?Workaround: Converted the mocha tutorial .mp4 file to .mov (Photo JPEG codec) and that does import into, and work with, mocha for After Effects. Imagineer Systems (mocha developers) claim that mocha supports .mp4, and the tutorial file is in .mp4 format, so I’m not convinced that .mp4 is the problem. At least I can work around it until I sort it out.

Thanks for taking time to respond to my inquiry.

have a great weekend,
Dave

mocha for After Effects supported file formats:
Image: http://i517.photobucket.com/albums/u335/davidp158/Screen-shot.jpg
mocha import file options, file types supported by mocha for After Effects

Mary - Thanks for your response. I will try your suggestion and post my results.
BTW, I am using a Mac, and video drivers are part of the OS X operating system. Thus, they can’t be “updated” per se. I have run the Apple Software Update to see if my system and QuickTime are current, and they are.

Mary,

Thanks for responding. BTW, I am using the Mac OS, not Windows.

Any advice on how to avoid re-installing After Effects and restoring plugins would be greatly appreciated. I can’t deal with this until I finish some projects, to avoid risking more down time and missing deadlines.

FWIW, I really wish mocha for After Effects was a separate installation for CS5. Its bad enough that Adobe doesn’t support mocha, but having to re-install After Effects and plugins is just crazy.

Dave

—Quote (Originally by MaryP)—
Hi David,

So, this sounds to me like something is definitely conflicting in windows, or on just that install of mocha AE. You could try backing up your brushes, menus, palettes, and plugins, but there’s not a good way to reinstall the version of mocha that comes with AE without installing AE again.

I will ask our team if they have any other suggestions before you go re-install AE to try to fix it.

Cheers,
Mary
—End Quote—

Mary,
Thanks for your response. I tried 32 bit mode, and although only one icon appears in my Mac OS X application doc, it still won’t import some files. Could this point to something within my OS that could be causing the import problem?
I also tried mocha under a different user account, but the results were the same.
Today I tried importing a file from a mocha tutorial from Michelele Yamazaki’s “Plug In To After Effects” book. The file was copied from the book’s DVD onto my hard drive, and plays fine in QuickTime, however it won’t load into mocha. As this is a file Michele uses in her tutorial, I have to assume is should work.
I tried to re-install mocha, however, the CS5 Master Suite installation discs do not offer an option to uninstall and install only mocha for After Effects. Instead, I have to replace my re-install After Effects. As I have other plugins already installed, I’m concerned about re-installing everything and creating new problems. Do you know if there is a way to re-install only mocha for After Effects? Those embedded installers are so inconvenient…
Any suggestions would be greatly appreciated.
Dave
—Quote (Originally by MaryP)—
Hi David,
I am also responding to your customer support ticket, so you can get back to me there if you like. 2 icons can sometimes mean the mediaioserver is showing up in the dock for some reason. You can try running in 32-bit mode.
Cheers,
Mary
—End Quote—

Mary,

Thanks for your response. I tried 32 bit mode, and although only one icon appears in my Mac OS X application doc, it still won’t import some files. Could this point to something within my OS that could be causing the import problem?

I also tried mocha under a different user account, but the results were the same.

Today I tried importing a file from a mocha tutorial from Michelele Yamazaki’s “Plug In To After Effects” book. The file was copied from the book’s DVD onto my hard drive, and plays fine in QuickTime, however it won’t load into mocha. As this is a file Michele uses in her tutorial, I have to assume is should work.

I tried to re-install mocha, however, the CS5 Master Suite installation discs do not offer an option to uninstall and install only mocha for After Effects. Instead, I have to replace my re-install After Effects. As I have other plugins already installed, I’m concerned about re-installing everything and creating new problems. Do you know if there is a way to re-install only mocha for After Effects? Those embedded installers are so inconvenient…

Any suggestions would be greatly appreciated.

Dave

—Quote (Originally by MaryP)—
Hi David,

I am also responding to your customer support ticket, so you can get back to me there if you like. 2 icons can sometimes mean the mediaioserver is showing up in the dock for some reason. You can try running in 32-bit mode.

Cheers,
Mary
—End Quote—

Mary,
Thanks for responding. BTW, I am using the Mac OS, not Windows.
Any advice on how to avoid re-installing After Effects and restoring plugins would be greatly appreciated. I can’t deal with this until I finish some projects, to avoid risking more down time and missing deadlines.
FWIW, I really wish mocha for After Effects was a separate installation for CS5. Its bad enough that Adobe doesn’t support mocha, but having to re-install After Effects and plugins is just crazy.
Dave
—Quote (Originally by MaryP)—
Hi David,
So, this sounds to me like something is definitely conflicting in windows, or on just that install of mocha AE. You could try backing up your brushes, menus, palettes, and plugins, but there’s not a good way to reinstall the version of mocha that comes with AE without installing AE again.
I will ask our team if they have any other suggestions before you go re-install AE to try to fix it.
Cheers,
Mary
—End Quote—

Mary - That’s a good suggestion. I’m downloading the file now, and will give it a try tonight or over the weekend.
cheers,
Dave
—Quote (Originally by MaryP)—
Hi David,
Ah, I’m sorry, I must have mixed that up with another case. Mac OS. Let’s try having you download a trial of mocha Pro? And see if that works? http://www.imagineersystems.com/single-download-view?filename=mochapro-2.6.1-4014.dmg
Install and activate that trial for two weeks, and see if that works on your OS. That way we can get a little closer to figuring out what is wrong if it installs and runs properly.
Cheers,
Mary
—End Quote—

Mary - That’s a good suggestion. I’m downloading the file now, and will give it a try tonight or over the weekend.

cheers,
Dave

—Quote (Originally by MaryP)—
Hi David,

Ah, I’m sorry, I must have mixed that up with another case. Mac OS. Let’s try having you download a trial of mocha Pro? And see if that works? http://www.imagineersystems.com/single-download-view?filename=mochapro-2.6.1-4014.dmg

Install and activate that trial for two weeks, and see if that works on your OS. That way we can get a little closer to figuring out what is wrong if it installs and runs properly.

Cheers,
Mary
—End Quote—

Update:

? Reinstalled After Effects, and mocha was reinstalled with it. Still won’t import .mp4 files.
? Reinstalled QuickTime v7.7., but no improvement
? Downloaded a demo version of mocha Pro (a different version that what ships with After Effects). This app was able to create a preview of .mp4 files, but the time line in mocha Pro only shows the first frame; no playback.

?Workaround: Converted the mocha tutorial .mp4 file to .mov (Photo JPEG codec) and that does import into, and work with, mocha for After Effects. Imagineer Systems (mocha developers) claim that mocha supports .mp4, and the tutorial file is in .mp4 format, so I’m not convinced that .mp4 is the problem. At least I can work around it until I sort it out.

Thanks for taking time to respond to my inquiry.

have a great weekend,
Dave

mocha for After Effects supported file formats:
Image: http://i517.photobucket.com/albums/u335/davidp158/Screen-shot.jpg
mocha import file options, file types supported by mocha for After Effects

Martin,
Thanks for your reply. Knowing why the second icon appears in the dock takes some of the mystery out of it, but if I am not supposed to see it, could there be something in my Mac’s OS that needs repair? I have run Disk Utility, Disk Warrior, repair permissions, and even tried running mocha with a different user profile. I’m anxious to get mocha working, as After Effects’ tracker is very limited.
Regarding .mp4 files, I will just convert them to Photo JPEG for now. I am new to video, and have a lot to learn about the myriad of file formats…but I want to be able to accommodate whatever comes my way.
Two other issues that my suggest a conflict between mocha and my machine:

  1. The “Film Back Size” text (mm, inches, width, height - see screen grab) in the “Film” tab, is cropped on my machine. Resizing the work space, or flipping through different tabs doesn’t redraw it any differently. It appears that the interface is cropping the top and bottom of the text.
  2. I also find changing numerical values via scrolling extremely hard, regardless of my user preferences for the default circular rotation, or the more traditional left/right scrolling method. I can’t get my cursor to find the “hot spot” that enables the scrolling feature. Instead, the numerical text is highlighted.
    Any suggestions are appreciated and welcomed.
    cheers,
    Dave

Martin,

Thanks for your reply. Knowing why the second icon appears in the dock takes some of the mystery out of it, but if I am not supposed to see it, could there be something in my Mac’s OS that needs repair? I have run Disk Utility, Disk Warrior, repair permissions, and even tried running mocha with a different user profile. I’m anxious to get mocha working, as After Effects’ tracker is very limited.

Regarding .mp4 files, I will just convert them to Photo JPEG for now. I am new to video, and have a lot to learn about the myriad of file formats…but I want to be able to accommodate whatever comes my way.

Two other issues that my suggest a conflict between mocha and my machine:

  1. The “Film Back Size” text (mm, inches, width, height - see screen grab) in the “Film” tab, is cropped on my machine. Resizing the work space, or flipping through different tabs doesn’t redraw it any differently. It appears that the interface is cropping the top and bottom of the text.

  2. I also find changing numerical values via scrolling extremely hard, regardless of my user preferences for the default circular rotation, or the more traditional left/right scrolling method. I can’t get my cursor to find the “hot spot” that enables the scrolling feature. Instead, the numerical text is highlighted.

Any suggestions are appreciated and welcomed.

cheers,
Dave

Hi Dave,
While we support mp4, we don’t recommend using it as the compression can be slow and sometimes problematic, especially when looping backwards in the timeline.
The reason you see 2 icons is that we have to load a secondary process to handle QuickTime files in 64-bit mode, which is why you only see it when you import the file. You should not see this second process in the dock, but we have seen it occur on some systems.
Originally the black screen was related to a QuickTime issue with Snow Leopard, which was fixed in both our software and in Apple’s updates. If you could send us the file to take a look at, that would help us work out the problem with this particular file in relation to your setup.
At any rate, the workaround you did is the best to way to avoid the format issues. In general we recommend converting to image sequences, but photo-JPG and Animation also work just as well.

Hi Dave,

While we support mp4, we don’t recommend using it as the compression can be slow and sometimes problematic, especially when looping backwards in the timeline.

The reason you see 2 icons is that we have to load a secondary process to handle QuickTime files in 64-bit mode, which is why you only see it when you import the file. You should not see this second process in the dock, but we have seen it occur on some systems.

Originally the black screen was related to a QuickTime issue with Snow Leopard, which was fixed in both our software and in Apple’s updates. If you could send us the file to take a look at, that would help us work out the problem with this particular file in relation to your setup.

At any rate, the workaround you did is the best to way to avoid the format issues. In general we recommend converting to image sequences, but photo-JPG and Animation also work just as well.

It’s still not entirely clear why the mediaio icon appears on some systems. It may well be a permissions problem but we’ve been unable to narrow it down as yet. Keep in mind that seeing this other process on the dock shouldn’t affect the program itself.

The field cropping is a bug we fixed in a later version, however if you drag the dotted bar between the parameter panel and the viewer up it should make them right.

For the scroll controls it helps to hold down the mouse over the number when you rotate or drag.

It’s still not entirely clear why the mediaio icon appears on some systems. It may well be a permissions problem but we’ve been unable to narrow it down as yet. Keep in mind that seeing this other process on the dock shouldn’t affect the program itself.
The field cropping is a bug we fixed in a later version, however if you drag the dotted bar between the parameter panel and the viewer up it should make them right.
For the scroll controls it helps to hold down the mouse over the number when you rotate or drag.

Hi David,
I am also responding to your customer support ticket, so you can get back to me there if you like.
Cheers,
Mary

Hi David,

I am not sure what weird issue is going on with you icons, but I would try a re-install of the software from scratch.

As for black frames, that could be one of several things. Either the codec is something that mocha doesn’t like and it can’t read it, or you need to update your graphics card drivers (find what model your card is and get the latest driver off their support site) and make sure you have the latest version of quicktime.

If you want to test to see if it’s the codec, try loading in a TIFF or JPEG sequence and seeing if that also loads black. If either sequence loads fine, we definitely have a codec issue. You’ll need to try a different codec setting for your footage going into mocha.

Let me know how this goes!

Cheers,
Mary