Black screen / Mocha won't load

Whenever I try to open up Mocha from After Effects I get a black screen. I get the initial pop-up box to Start but after that, it’s a black screen with no loading wheel for my mouse even. I’ve tried uninstalling and reinstalling After Effects twice, didn’t work. I have also tried deleting Mocha preferences and restarting my laptop twice (a solution I saw from another forum post), which also did not work. My laptop specs:

  • Microsoft Office 10 Version 1903 (OS Build 18362.720)
  • Graphics card: I don’t think I have one, just the Microsoft Basic Display Driver
  • After Effects Version 17.0.5 (Build 16)

Here are the pics of the black screen and an error message that pops up every time I try to close the black screen.


2020-04-02 (2)

Can you try turning off GPU processing in Mocha preferences? Go to file>preferences and the GPU tab, then uncheck the box for using the GPU. Then restart AE and try again. Please let me know if that works for you. If not, can you please go to help, view log, and attach the latest long entries? We will get to the bottom of this for you.

Thank you,
Mary

Hi Mary,

I cannot access Mocha preferences because the regular Mocha window never actually opens. It’s just a black screen with nothing to click.

Thank you

The first thing you need to determine is what your actual system setup is.

Please go here:
C:\Users[YOUR USER NAME]\AppData\Local\Imagineer Systems Ltd\

Where [YOUR USER NAME] is the name of the folder is the same name as your login user name.

Then grab the “imagineer.log” file and attach it to this thread via the “upload” button in a new reply:

imagineer - Copy.txt (46.9 KB)

Thanks

Ok this seems to confirm that you don’t have a graphics card, which is surprising.

Can you go to your system information app and open the “Display” section under “Components”:

Then screen grab the information on the right-hand side? This will determine what your current display cad is.


Empty actually.

You need at minimum a GPU that can run OpenGL 1.2 and CPU tracking needs OpenGL 2.0.

You’re sure you don’t have any form of GPU installed that perhaps is not working? What type of machine are you using?

You can also try to manually turn off the GPU settings.

You can disable the GPU processing via preferences. As you are on Windows, here is the procedure:

Quit the after effects and try this:

  1. Open Regedit.exe on windows (or search for “registry editor” in the start menu)
  2. Navigate to HKEY_CURRENT_USER\Software\Imagineer Systems Ltd
  3. Locate your preferences entry. It will be “Mocha AE CC” or similar
  4. Under the Mocha preferences, look for the following properties set the values to false :
  • EnableCLTracker
  • EnableCLImageProc
    You may not have both these values.
  1. Reopen Mocha

The values above will disable GPU preferences so we can see if this has any effect on opening the program.

My laptop model:

I have also been getting this error when I open Mocha:
2020-04-08 (1)

Your laptop has Intel HD Graphics 5500 which should be able to run Mocha, but you need to install the correct video driver from the DELL support website.

this appears to be the most recent driver for the Intel HD Graphics 5500:
https://www.dell.com/support/home/au/en/aubsd1/drivers/driversdetails?driverid=tdrnk

Try installing this and see how you get on.

It appears that the newest driver is not compatible with my laptop. Also, thanks for the help so far, I appreciate it.

Go to the DELL support page and enter the service tag for your computer, select Drivers & Downloads, then choose Operating system: Windows 10 and Category: Video. You should see a single result on the page which is the driver for your computer. It’s a slightly older version than the one Martin linked to, but should still work.

The drivers seem to have done the trick. Mocha is finally opening normally now. Thank you!