Black Screen on some, not others

Ok, so I’ve been trying to import clips into Mocha for tracking, and up until today I’ve had a bundle of errors. Anything other than PNG sequences would either result in a black screen (h.264 mp4 video) to a crash of the mediaioserver.
Today, just before going to post this issue, I try a clip I had rendered to upload to a client’s YouTube (h.264 mp4 format) and lo and behold, I get video picture in Mocha. So I try and render out the two clips I want to work on in that format, and both display a black screen in Mocha. One has more frames than the clip I had working, and one has less, so it’s not size.
I am using Windows 7 64-bit, Adobe CS5, and the bundled Mocha. What format should I use for high definition processing in Mocha? Is there a fix for this black screen issue? What am I missing? Right now Mocha seems to have a life of its own, only accepting the clips I don’t care to track… :frowning: I’d much rather not have to export as PNG every time I need to do tracking.

In general we don’t recommend using compressed QuickTime formats for tracking. Compressed formats, especially ones like mp4 and h264 can alter the number of frames and throw off your track being syncronised correctly. There have been cases where for example a 30 frame h264 is read as 29 or even 31 frames in different applications it’s rare, but be aware of it just in case!
We are looking into the h264/mp4 issue as we know this is a common format to both compress to for quick viewing and is also often the format from captured from disk-based cameras.
Because PNG does lossless compression you can experience a slight slowdown as mocha interprets the information. You could also try uncompressed TIF which may speed up the process.

In general we don’t recommend using compressed QuickTime formats for tracking. Compressed formats, especially ones like mp4 and h264 can alter the number of frames and throw off your track being syncronised correctly. There have been cases where for example a 30 frame h264 is read as 29 or even 31 frames in different applications it’s rare, but be aware of it just in case!

We are looking into the h264/mp4 issue as we know this is a common format to both compress to for quick viewing and is also often the format from captured from disk-based cameras.

Because PNG does lossless compression you can experience a slight slowdown as mocha interprets the information. You could also try uncompressed TIF which may speed up the process.

PNG sequences should be fine. Usually HD is a Square Pixel format, so you should not have to alter the aspect ratio. What is it being imported as?
Also, try updating your graphics drivers, as this can play a role in viewer problems on Windows.

PNG sequences should be fine. Usually HD is a Square Pixel format, so you should not have to alter the aspect ratio. What is it being imported as?

Also, try updating your graphics drivers, as this can play a role in viewer problems on Windows.

We are looking into a solution that may avoid this problem in future, but i’m glad you’re up and running again!

Ok, so I’ve been trying to import clips into Mocha for tracking, and up until today I’ve had a bundle of errors. Anything other than PNG sequences would either result in a black screen (h.264 mp4 video) to a crash of the mediaioserver.

Today, just before going to post this issue, I try a clip I had rendered to upload to a client’s YouTube (h.264 mp4 format) and lo and behold, I get video picture in Mocha. So I try and render out the two clips I want to work on in that format, and both display a black screen in Mocha. One has more frames than the clip I had working, and one has less, so it’s not size.

I am using Windows 7 64-bit, Adobe CS5, and the bundled Mocha. What format should I use for high definition processing in Mocha? Is there a fix for this black screen issue? What am I missing? Right now Mocha seems to have a life of its own, only accepting the clips I don’t care to track… :frowning: I’d much rather not have to export as PNG every time I need to do tracking.

Ok, after a lot of testing and trial, it seems the only thing I had to change was the audio… It is the only setting that seems to change from the standard h.264 1080P 29.97fps preset that I was using and the the Mocha friendly one I found by accident is the audio setting.
In the standard preset it is 160kbps, and in the Mocha friendly saved preset I now am using, it is 128kbps, both AAC.
I tried previously to import clips without audio, but I am unsure if I only tried that for MPEG 2 or for both it and mp4/h.264.
MPEG 2 still crashes out mediaioserver, forcing a shutdown of Mocha to restart.
Hopefully this will help anyone else out there experiencing the same type of error. I’ve had much better tracking success in the imported mp4 than in the previous version of png sequence I used, and am currently half done one scene in far less time.

Ok, after a lot of testing and trial, it seems the only thing I had to change was the audio… It is the only setting that seems to change from the standard h.264 1080P 29.97fps preset that I was using and the the Mocha friendly one I found by accident is the audio setting.

In the standard preset it is 160kbps, and in the Mocha friendly saved preset I now am using, it is 128kbps, both AAC.

I tried previously to import clips without audio, but I am unsure if I only tried that for MPEG 2 or for both it and mp4/h.264.

MPEG 2 still crashes out mediaioserver, forcing a shutdown of Mocha to restart.

Hopefully this will help anyone else out there experiencing the same type of error. I’ve had much better tracking success in the imported mp4 than in the previous version of png sequence I used, and am currently half done one scene in far less time.

Thanks Martin! I’ll try your suggestions. I did use PNG three times, the first was very successful, but the second and third time I had very unsuccessful tracking, but with h.264 it tracked smoothly, so I’m not sure what I did wrong. What format settings should PNG use for a 1080p sequence? I used 1920x1080 output resolution, but I had to uncheck the link between the height/width of the footage to do it. Was this a mistake?
So far I’m very happy with the results since I got h.264 imported as far as setting up tracks, but I guess we’ll see when it comes to importing into AE.
I look forward to picking up tips and tricks here, as well as hopefully being an asset to the community once I get to the far side of the learning curve. :slight_smile:

Thanks Martin! I’ll try your suggestions. I did use PNG three times, the first was very successful, but the second and third time I had very unsuccessful tracking, but with h.264 it tracked smoothly, so I’m not sure what I did wrong. What format settings should PNG use for a 1080p sequence? I used 1920x1080 output resolution, but I had to uncheck the link between the height/width of the footage to do it. Was this a mistake?

So far I’m very happy with the results since I got h.264 imported as far as setting up tracks, but I guess we’ll see when it comes to importing into AE.

I look forward to picking up tips and tricks here, as well as hopefully being an asset to the community once I get to the far side of the learning curve. :slight_smile:

Sorry for the delay, been very busy. I’ve tracked down the issues over the various testing tricks I’ve done. It seems, when I export my AVCHD clips from Premiere to h.264 that it was adding a black frame on the end unless I specifically made sure to reduce by one frame, and that last black frame was what seems to be messing up Mocha. As long as I trim it, Mocha imports, but if I don’t it is all black screen on import. Hope that helps track down an import issue that might be causing it.