Blurry UI toolbar

Hi, I just started using Primatte Studio on a 2018 6 core MacBook Pro with 32 G RAM on Catalina 10.15.6 with Davinci Resolve. The UI Toolbar is so blurry, I can’t even read it. Any suggestions? Is there a setting that I’m not seeing?



Have you tried adjusting the resolution of your screen to see if that brings back the clear text in the Primatte toolbar?


Did anyone ever figure this out? I am having the same problem.

Hi Steve,

We acknowledge that with some hardware configs the toolbar text is garbled in Resolve and we’re working to fix that. Could you please send along some of the specs of the machine that you’re working with? We would like to know the OS version, version of Resolve, version of Continuum, number of attached displays, monitor resolution and if any scaling has been applied to the display via system controllers.

Please feel free to send that to me privately if you prefer.


Hey Guys!

I have the same problem.

Running on:
Davinci Resolve Studio 17.2.2 BUILD 4
MacOS Big Sur 11.4
MacBook Pro (16 inch, 2019)
CPU 2.3 GHz 8-Core Intel Core i9
RAM 64 GB 2667 MHz DDR4
GPUs AMD Radeon Pro 5500M 8 GB
Intel UHD Graphics 630 1536 MB

Unfortunately, at the present time this is a fact of life with certain monitor configurations on Mac OS. We are still trying to arrive at an acceptable solution for the issue, which only affects particular multi-monitor configurations.

Meanwhile, here is a screenshot of the Primatte Studio toolbar taken from within Resolve on my Mac that you can use as a reference as I’m sure you don’t want to adjust the screen resolution on your system or unplug any secondary monitors.


It’s been 2 years and this issue still hasn’t been addressed? Working on a brand new Macbook Pro (M1 Max). I tried using an external monitor and I have the same issue. Could you please look into this, it makes the otherwise great plugin completely unusable.


Thanks for pushing this conversation forward - I’ll raise the issue again with engineering to see if they can spend more time on this. And I agree - in Nuke on Mac OS the Primatte Studio toolbar is pretty much useless in its current state and you’ll have to rely on using the parameters in the control panel to use the filter in that host on that OS.


Having the same issues since forever, would love to see a resolution. The menu is still all burred and nobody seems to have an urgency.