[build 9.g7a500571e508] Fixed Frame preference not sticking

Mocha Pro 2020 Version 7.0.4 Running on Windows 10

So Mocha seems to not be respecting the Fixed Frame offset in preferences.

If I go to File>Preferences>Clip and set the Fixed Frame Offset to 1001 and hit ok.
Then I go to
File>New Project>Import clip (choose a clip)
Mocha will have “Fixed frame” checked, but it will not be set to 1001. It will be set to whatever the first frame is of the clip I chose.
If I hit “reset” it will then go to 1001.

Mocha should always default to 1001 if I have that setting in the preferences.

Mocha Pro 2019 worked this way. I’ve tested it on Mocha Pro 2019.5 Version 6.1.0 and it worked fine.

My worry with this, is the fact that our studio keeps timecode in the file names. However while we work in various DCCs we always start projects at 1001. If an artist doesn’t hit reset every single time in mocha then they will export their tracks/roto at the wrong timecode for their DCC.

Anyone have any ideas? I sent a support ticket as well but I also thought I would try here.

Thanks for letting up know and reporting it so succinctly! We’ll investigate and get back to you.

This is easily reproducible. We’ll flag a defect and try to get a fix in for the next update.

Just to let you know we’ve identified and fixed this problem. It will be in the next major update.