[build37] - After Effects keeps crashing after I track a spline in Mocha Pro

VERSION: 9.5.3 build 37.g93a5a2e98a2d

PLATFORM: iMac, MacOS Monterrey (12.3.1), Processor 3.8 GHz 8-core Intel Core i7, 64 GB 2667 MHz DDR4, AMD Radeon Pro 5700 8 GB

DESCRIPTION: In After Effects, I put the Mocha Pro effect on a 4096x2160p clip to track a 2D hole JPG on to the talent’s face. I opened the Mocha Pro app, created a track, imported the JPG, then saved and closed Mocha. When I try to adjust Module Renders for Mocha in After Effects, it crashes and generates an auto-saved project file.

STEPS TO REPRODUCE:

  1. Apply Mocha Pro effect to clip in After Effects
  2. Create a tracking spline with Perspective & Mesh enabled, then track
  3. Check off “PowerMesh Warp”, import and position the hole PNG, then save and close Mocha Pro
  4. In After Effects, open Effect Controls for the clip that has the Mocha Pro effect
  5. In the Mocha Pro controls under “Module Renders”, check off the “Render” box and switch the “Module” dropdown to “Insert: Cutout”

EXPECTED RESULT: the PNG should appear and be tracked to the footage.

ACTUAL RESULT: After Effects crashes, and generates an auto-saved project file. These auto-saved project files crash immediately when opened, and generate new auto-save files with the same problem.

REGRESSION: Unknown, working off of the latest versions of Mocha Pro and After Effects.

ATTACHED: Crash log from After Effects.
Error Report.pdf (42.0 KB)

LINKED: Copy of log from Mocha
https://drive.google.com/file/d/119hovmsCwPLRITQmi0mXKCb7fi6XZaVy/view?usp=sharing

Can you please try the following:

  1. Start a fresh AE project
  2. Apply Mocha Pro to a new layer
  3. Open Mocha
  4. Go to preferences
  5. Under the “GPU” tab, change your OpenCL Device from “Automatic” to your Radeon card.

Can you also please attach the AEP project? I don’t need the footage, just the project file.

Are you importing the image via the “Import…” option in the Insert clip drop-down?
What happens if you import the PNG via the After Effects timeline instead?

I was importing via the Insert clip drop down. I would have imported in After Effects, but I don’t know the best way to export tracking data from Mocha Pro (I know Mocha AE can send out keyframed Corner Pin FX though).

I tried changing to Radeon, and it still crashed with a similar error message.

I’m including the AEP files (both the original and the 2nd Pass with Radeon enabled) as Google Drive links below:
https://drive.google.com/file/d/19GWYUN1jRSh9KO3plHV0UccdKVE0h4Qt/view?usp=sharing
https://drive.google.com/file/d/1kUFtIPuwNKOxgPHEtHb-OcKD_G0lhtz-/view?usp=sharing

I’m going to be unavailable for the next few hours though.

Thanks. I don’t see a crash when I open this project, so the next step will have to be getting the footage. If you want to send that separately via PM for privacy that’s fine.
There appears to be an issue with the file itself from what I can see in the logs, but it’s unclear.

Try moving the Insert JPG file to another location on your hard drive to see if the project will open when it can’t find the file.

In the meantime, I’ve exported the Mocha project file so you can re-import it into a fresh plugin:
hole-track_V1.mocha.zip (6.8 MB)

My mistake: the AEP files I sent you weren’t the ones that were crashing. Can you please open the project, go to Effect Controls for the layer with Mocha, then under Module Renders > Module, and change the dropdown menu to Insert: Cutout? That was what made it crash.

I’ll send you the AEP files that kept quitting later, and I’ll PM you the footage as well.

I’ll try your file and your fix with the JPG too.

There was no crash when I switched to Insert:Cutout, even when I imported my own JPG to replace the missing one.

This suggests something system-specific, but try out those ideas first.
I’ve sent the dev team your error log to see if they can determine the exact place where the crash is occurring.

Sorry, I don’t know how to import the Mocha project file you sent me, can you please let me know how to do it when you get this? My license only covers Mocha Pro in After Effects.

In the meantime, I’ll PM you the AEP files that kept quitting, along with the JPG I used for the project along with the footage.

You just apply the plugin to a new version of your footage, open the Mocha UI, and either Open or Merge the project file from the file menu.

Ok. Can you please tell me how I can PM you? I couldn’t find the option on your page.

Wait, I think I was able to PM them to you through the Facebook group. Let me know if you have any issues receiving it. I’m going to go AFK for a while, but thanks for being available at this hour!

Thanks, I was able to reproduce the crash using your project. Now I’ll see if I can find out why it’s causing a problem.

There’s definitely something wrong with that Insert JPG file. I fed the JPG via After Effects instead and there was no crash. I tried it in a basic project and it also crashed.

I’m going to give this particular JPG to the dev team to see where the corruption is, but try opening it in another program like Photoshop and re-saving it, then give it another go.

After further investigation, I think it’s because your image is grayscale, not RGB. Try converting it to an RGB image and see if you get the same problem.

1 Like

It worked, no crash!

Thanks! I only intended this image as a temp asset, but I’ll remember that about greyscale in the future.

2 Likes

I should clarify that this happens when the image is very specifically only Greyscale, as in the image doesn’t contain RGB channels, only gradients of grey.

I’ve flagged this as a defect on our end as we should just handle the image gracefully and not crash!

1 Like