Camera solve jumpy

Using Mocha Pro 4.1.2 (and 4.0.1)
I have a shot with six perspective tracked surfaces (none are coplanar) which I need a 3D camera solve to send to After effects.
3 of these surfaces are partial tracks as the tracking feature disappears or appears mid shot.

I solved the 3D camera (Large parallax, All focal lengths checked, Zooming off) and got 98% solve quality.
I then Exported the camera data to After effects 3D Motion data (copied to clip board). It warned me about low accuracy nulls.

In After effects the resulting tracked camera was perfectly matching except for the frames where the tracking stopped or started on those partially tracked surfaces. On these frames the camera jumps significantly.

I went back to mocha and re-ran the camera solve, this time without those 3 partial surfaces. The result was 85% quality track. In After effects I got a perfect match with no jumping.

Based on what I have learnt from mocha documentation and online tutorials, the camera solve is supposed to be able to deal with partial tracks so long as there is enough tracking data from other splines to compute the camera. This was the case for me since I ended up only using the 3 full tracks anyway.
For future shots I may not be so lucky and may only find partial tracks to rely on, so how can I avoid the jumpy camera solve?

Thanks

In the future, try to get those partial tracks to overlap more on the timeline. They need a lot of overlap in order to solve for the 3D correctly. I am glad you were able to work out your shot regardless though.

That should fix it in the future. If you have any more questions, please let me know and I will be happy to help.

Hi Mary,

Thank you for your reply.

I’m working on another shot now (27 second long) which only has two features which stay in shot the whole time and they are coplanar!
I’ve tracked five other features which are partial but all have plenty of overlap (minimum of 70 frames).

The resulting camera solve rendered from AE, jumps every time a feature starts or stops mid shot.
Is there perhaps something extra I need to do in Mocha to tell it to ease in/out of each tracked layer?

 

When you turn the grid and surface tools on, are your tracks rock solid?

Thank you Mary, I rechecked and found one of the 5 partial tracks was not completely rock solid so I got rid of it. Solving the camera then showed one less jump in motion but the other jumps were still present (solve quality reduced to 88%).
I removed the remaining 4 partial tracks one by one, solving in between and checking for jumps. Each time I removed a track the corresponding jumps disappear but the solve quality goes down. Once I removed all partial tracks I was left with the 2 full length coplanar tracks mentioned above, and one additional full length track I had since made which gave a solve quality of only 50%.

In the end I went back to using the 4 good partial tracks and managed to edit the camera position/rotation in after effects to iron out the jumps.

You should also just be able to take the jumpy keyframes out of the track by either changing the parameters you are using to track (translation, scale, rotation, shear, and perspective), or simply deleting the trouble keyframes in the dope sheet. You don’t have to remove the whole track.

Thank you for the tips, Mary.
I did once try to remove tracked keys to get rid of a jump, but the jump just relocated to the new finish point of the tracking data. I will try it again! :slight_smile:
Currently all my tracks have everything ticked (translation through to perspective) so I will uncheck some tracking parameters too, and see if that helps!

For problem areas, definitely unchecking shear and perspective will help.

Thank you, Mary.