Camera tracking data in Fusion


#1

How can I get position data of the camera tracker into Fusion?
After importing the fbx I get a point cloud, nothing is labeled or marked its just a messy pile of points - what I really need is position tracking of a particular object in the scene. There is a tutorial on how to do this with AE - but how is it done in Fusion?


#2

When you export an FBX out of Mocha you should get the camera data and a Null/Point for each corner of the selected surface. So if you have only one layer selected you should have 5 cloud points (4 corners & center) and the camera.


#3

Yes, I understand the nulls. I do get a null for the moving object, but its not animated, doesn’t move.
To be more clear - I tracked the camera, all is good. Then I track a moving object in the scene and export camera again. Now I expect to get 3D tracking data of that object when I add the second fbx. But there is only a static null for the moving object. Don’t see any 3d tracking data of the moving object.


#4

After you Solve Camera in Mocha, are you selecting the “moving tracked object layer” and then exporting FBX? If you have the time to upload the project for us, we can take a look.

If you need to upload privately, you can contact me: RossS (AT)BorisFX (Com).


#5

As an aside, you may want to double check that you’re exporting the correct layer, it may be that you’re exporting the tracked background layers instead of the moving object layer.


#6

Something strange is going on reg. selecting layers to include in camera solve.
When I start a fresh project, I turn off tracking after each layer is tracked, that is the normal way of tracking. Then I select all layers by highlighting them and then camera solve. Actually camera solve will always use all the layers regardless if they are selected or not. All is good - except when I export fbx I always get nulls of all the layers, regardless of what is selected.
That works up until I get a failed camera solve. Then it somehow “snaps” into a different mode. From then on I have to re-enable tracking for each layer to include in camera solve, without tracking enabled camera solve is greyed out, it will only use layers with tracking enabled.
Maybe that sounds confusing - because it is.

(Mocha Pro OFX with Fusion)

PS: When I restart sometimes the problem is cleared and things are back to normal and sometimes not. Today I reopend my project and camera solve works without any layers selected. Yesterday I had to turn on tracking for each layer for camera solve to work.


#7

That sounds very odd, definitely send us the project and I will take a look.

Cheers,
Mary


#8

sent to Ross


#9

Hi George,

I just wanted to see if you managed to get the results you were looking for in the end?

I tried this myself and noticed that our user guide currently has incorrect instructions for the camera solve module. We’re going to fix it as soon as possible. For a moving object solve, you need to:

  1. Track your layers as normal
  2. Switch to the camera solve module
  3. Turn on the cog/gear icon for each static layer, i.e. layers that don’t move relative to the camera. These are the layers that will be used to solve the camera motion. The crucial point when you are working with moving objects is that their cog/gear must be OFF when you solve.
  4. Press solve
  5. Now select the layers you want to export - might be just a single moving layer in this case.
  6. Press export camera data and proceed as normal.

I hope this helps, please let me know how you get on.

Best regards,

J-P


#10

George, can you try this from JP and see if it fixes your issue?