Can Mocha actually *work* in AE?

Okay, pretty obviously a loaded question but I’m having some real issues trying to use this with anything other than an extremely simple tracking problem (one in which I can easily use the built-in AE tracker and not bother with Mocha). I’ve seen plenty of examples of folks who seem to do a lot more but for the life of me I’m not getting close.

Here’s the dealio: On handheld footage which has one zoom out, but clear views of about 1/4 of the ground plane (sharp and in focus) I’d like to create a track that I can pin another layer to – doesn’t need shear or perspective, but needs to hold that track solidly to the footage. I seemingly create such a track in Mocha, align the surface, and export just the transform data (although I’ve tried with corner pin as well) and import into a null which, while in general stays in the right position, still floats around as if it’s not quite holding onto the footage (almost as if the null itself was handheld in relation to the shot, if that makes sense). I’ve even tried the MochaImport Plugin to facilitate this process, with the same lack of success.

(Incidentally, what I’m really trying to do is shown in this tutorial: VIDEO COPILOT | After Effects Tutorials, Plug-ins and Stock Footage for Post Production Professionals although my shot also includes a zoom halfway through, which does stop and even after the zoom I continue to have these floating issues).

Either there is something I’m doing very wrong or Mocha just isn’t the right product for me, but I’d sure like some guidance here. TIA for any help.

Hi Mike,

Which version of mocha AE are you using? This will help me tell you how to deal with the data, but let’s first look at the usual suspects:

  1. Check your frame rate matches between the two applications. Both mocha and AE assume a certain frame rate for files so make sure they are in sync!

  2. Make sure the aspect ratio and dimensions match. Same deal as point (1) here. Sometimes the two apps can interpret footage differently.

  3. Make sure the data you’re pasting is at the right point on the timeline. For most people this will be at the beginning of the shot, but if you’re only tracking a portion of your shot, make sure it’s lined up in AE before you paste.

If you’re still stuck, please send us the project files to support@imagineersystems.com and we can take a further look.

I had those three things checked, but thanks for reminding me.

I tried it again with a somewhat simpler shot and I think I have it working more or less properly. I suspect the main issue was I was trying to use a shot that was just a bit too much for either me or Mocha (or both). There’s a lot to learn in all of this and I do recognize I am at the early stages of this process.

Thanks as well for the reply and offer – I may well take you up some time when I really get stuck.