Cannot Export to After Effects CS4

A couple of days ago, I purchased Mocha v 2.0.1
Now my After Effects CS4 does not understand Mocha’s export format. I cannot paste in any data I export from Mocha.
I fired up the old version of Mocha I have, and it works as always. What am I doing wrong with he new version? I tried all export formats for After Effects.

A couple of days ago, I purchased Mocha v 2.0.1
Now my After Effects CS4 does not understand Mocha’s export format. I cannot paste in any data I export from Mocha.
I fired up the old version of Mocha I have, and it works as always. What am I doing wrong with he new version? I tried all export formats for After Effects.

—Quote (Originally by jabloomf1230)—
Other than saving it as txt, the only other option (which is worse) is to paste…
—End Quote—
Hi Jabloom :slight_smile:
There is yet another option - I am a programmer (my profession) and I will write a utility to do this automatically. (Video is my hobby, at least for the time being.)
Stay tuned!
ingvarius

I have found the culprit:
It is copying to the clipboard that does not work. When Mocha is copying to my Vista clipboard, the carriage return x0D (byte 13) is missing, only the line feed x0A (byte 10) is there.
When I save to a TXT file instead of copying to the clipboard, all is fine, both line feed and carriage return is saved.

I think this is a Mocha “feature” and not a Vista issue, since previous versions of Mocha work fine with my Vista clipboard. Many others than me must have run into this…?

I hope there is a solution, saving to TXT, when experimenting, is rather cumbersome.

I have found the culprit:
It is copying to the clipboard that does not work. When Mocha is copying to my Vista clipboard, the carriage return x0D (byte 13) is missing, only the line feed x0A (byte 10) is there.
When I save to a TXT file instead of copying to the clipboard, all is fine, both line feed and carriage return is saved.
I think this is a Mocha “feature” and not a Vista issue, since previous versions of Mocha work fine with my Vista clipboard. Many others than me must have run into this…?
I hope there is a solution, saving to TXT, when experimenting, is rather cumbersome.

jabloom,
yes correct, it “looks like a mess” because Notepad does not honor the line feed(byte 10). If I paste into Word, it looks ok because Word honors the line feed only. Notepad wants both the carriage return (byte 13) and the line feed in order to insert a line-break.
It may well be a Vista bug, but if - the question is why my older versions of Mocha can do this just fine, on the same machine running Vista.
Judging from this, I call it a bug, and I hope ImagineerSystems will fix it soon. Saving to TXT is ok, but why do it in a complicated way now with the newest version, when I can do it the fast and easy way with my two older versions of Mocha?

jabloom,
yes correct, it “looks like a mess” because Notepad does not honor the line feed(byte 10). If I paste into Word, it looks ok because Word honors the line feed only. Notepad wants both the carriage return (byte 13) and the line feed in order to insert a line-break.
It may well be a Vista bug, but if - the question is why my older versions of Mocha can do this just fine, on the same machine running Vista.
Judging from this, I call it a bug, and I hope ImagineerSystems will fix it soon. Saving to TXT is ok, but why do it in a complicated way now with the newest version, when I can do it the fast and easy way with my two older versions of Mocha?

—Quote (Originally by jabloomf1230)—
Other than saving it as txt, the only other option (which is worse) is to paste…
—End Quote—
Hi Jabloom :slight_smile:
There is yet another option - I am a programmer (my profession) and I will write a utility to do this automatically. (Video is my hobby, at least for the time being.)
Stay tuned!
ingvarius

That bug was been around in some form since MS released Vista. Saving to txt works fine. The bug has disappeared for me with Windows 7. Why I don’t know.
If you paste from Mocha to Notepad, I assume that it looks like a mess, right?

That bug was been around in some form since MS released Vista. Saving to txt works fine. The bug has disappeared for me with Windows 7. Why I don’t know.

If you paste from Mocha to Notepad, I assume that it looks like a mess, right?

Other than saving it as txt, the only other option (which is worse) is to paste the clipboard contents to Word and change all occurrences of the special character {LF} to {CR}{LF} , then Select “All” and copy to the clipboard again.

I only mention this option, because some people don’t like to have a bunch of unidentifiable txt files laying around on their hard drive.

The first time that this bug showed up for me, was with V2.0 of mocha for AE (which is 32 bit), running under Vista x64. The bug persisted with the 64 bit full version of mocha. If you search this message board, you will find threads that discuss the issue.

Other than saving it as txt, the only other option (which is worse) is to paste the clipboard contents to Word and change all occurrences of the special character {LF} to {CR}{LF} , then Select “All” and copy to the clipboard again.
I only mention this option, because some people don’t like to have a bunch of unidentifiable txt files laying around on their hard drive.
The first time that this bug showed up for me, was with V2.0 of mocha for AE (which is 32 bit), running under Vista x64. The bug persisted with the 64 bit full version of mocha. If you search this message board, you will find threads that discuss the issue.