Cannot import ANY footage to Mocha

Hi,
I have the Adobe production premium pack installed, along with Mocha.
Previously I had master collection cs4 installed,
Running on Mac Os x 10.6.7
Whenever I try importing any footage (Canon Eos 5d Mark II mov, GoPro Hero Mov, or canon 7d mov) nothing imports, I simply get errors
It says “the application quit unexpectedly” yet it still runs, and gives me errors “An error occurred, please try again” What kind of error is that? Why would you even included an error that doesnt explain the problem atleast slightly? Forum traffic low maybe?
I’m getting super annoyed that i cannot even import footage let alone track anything.
Specs
Quad core Intel Xeon,
12gb 1066 DDR3

The error sounds like QuickTime barfed. We use a helper program that runs in the background to load QuickTime files on 64-bit operating systems, when you see the application quit unexpectedly message it’s probably the helper application quitting. The reason the error message isn’t telling you anything is probably because the error that occurred isn’t one we expected might happen, so it doesn’t have a more detailed message. You could check the mocha log in Help | View Log in case there is more information there.
What version of mocha are you running (from the mocha | About… window)?
Do the files you are trying to open all open properly in QuickTime Player?
Unfortunately all the files you have tried to open will be very similar in terms of codec. These files should work though, some of the test footage we use is from a GoPro camera.

Yeah, the MPEG formats are actually quite poor for use in VFX, due to the overhead of reading the frames, and especially the poor performance when scrubbing backwards. It’s best to convert from MPEG to some format with I-frame-only compression when you have a multi-vendor VFX pipeline.

Can you try downloading the latest version of mocha AE from the Imagineer site and see if this also has the problem?

Try running in 32-bit mode. To do this, ctrl-click mocha in the Finder, then choose Get Info. In the next window tick Open in 32-bit mode.

OK, this is mysterious. Can you please post a short example video (1 sec is enough) we can try?

The project file doesn’t matter - it’s a footage problem.
If you export as an image sequence, JPEG is fine, then this is guaranteed to work in mocha.

h.264 is part of the MPEG-4 family - when I said MPEG, really I am generalising all codecs which use IBP frames, that is where you need to read a whole block of frames to be able to fully decode just one frame.

—Quote (Originally by traptsoul)—
the work machine is a G5 with 12gb ram, 2 x 512 gfx cards, 4TB hdd space, etc.
—End Quote—
Do you actually mean G5 or is it a Mac Pro?

HI traptsoul,
Again this will be a lot easier if we can see some of the footage. Tracking is highly subjective to the content of the shot and we can give specific advice when we can actually see what you’re dealing with.
We can provide an ftp if you need it. Content is kept private and deleted after use.
Some general tips:

  • With screens and monitors you will often get reflections: Try cutting them out by making a hole in the matte with Add to Spline.
  • Are there any obstructions coming in front of your tracked surfaces? If so, you may need to mask them out in order to get a good track.
  • Try tracking from where the screen is largest. The more detail you start with the more accurate the track can be. You can track backwards and forwards from the point you start at
  • Adjust parameters. Try using Auto Channel instead of Luminance and ramp up your Min % of Pixels used to about 90 if a track is slipping
  • Before you track, try setting up the surface and turn on the grid so you can see how the track is going while you track.
    If you haven’t already, I suggest watching the “Learn Mocha” series by Steve Wright:
    http://www.imagineersystems.com/learn-mocha

—Quote (Originally by traptsoul)—
Anyway when i got home I tried to import the same kind of footage into mocha on my imac, and it worked no problem.
It has the same setup, both mocha cs4 + cs5 installed, yet it worked.
—End Quote—
If this is the case, then there is clearly an issue on the other machine. What is difference between your home machine and the one you’re working on?
If mpeg streamclip is also playing up there is something strange going on with the system.
Do you have any administrator permissions set on that machine?

Hi!
I’m Mary poplin, one of imagineer systems product specialists. I’d like to call you and figure out what’s going on with your footage and tracking, can I do that sometime today? You can email me your number so you’re not putting it out on the forums.
Cheers,
Mary

Just to update here, I tried to import a h.264 mp4 file and it imports, however the screen remains black…
any ideas???

Version 2.2.1 CS5 Build 2932
Build date Jul 23 2010
Error Log:
May 17 11:44:13 (mocha for After Effects) Commenced logging at Tue May 17 11:44:13 2011
May 17 11:44:13 (mocha for After Effects) Build Date Jul 23 2010
May 17 11:47:26 (mocha for After Effects) # ??? Unknown exception thrown.
May 17 11:47:26 (mocha for After Effects) # File: Luthien.cpp
May 17 11:47:26 (mocha for After Effects) # Before line: 444
May 17 11:47:26 (mocha for After Effects) #
Yes, all work properly in quicktime.
Just to note, my mpeg streamclip stopped working a few months ago and I havn’t tried mocha since before then, I doubt this would affect it though.

—Quote—
Try running in 32-bit mode. To do this, ctrl-click mocha in the Finder, then choose Get Info. In the next window tick Open in 32-bit mode.
—End Quote—
Tried this in both Mocha cs5 and cs4

Is it possible you could supply me with an example project file I could try?

Downloaded this :
Product: mocha
Platform: Mac OS X Universal
Version: 2.5.2
Created: Feb 25,2011
Revision: 3520
Download: mocha 2.5.2 for Mac OS X Universal download
Was asked about purchasing activation?
Tried in trial mode, recieved error
“IPC protocol error : Incorrect message id recieved”

Not sure that it will help,
I tried to upload a file before I left the office last night but the uploader failed.
Anyway when i got home I tried to import the same kind of footage into mocha on my imac, and it worked no problem.
It has the same setup, both mocha cs4 + cs5 installed, yet it worked.
I can’t see what the problem is!
It simply says “An error occured, please try again” and it says this if I press “ok” or even if I try to cancel the new project window (after ive tried the import).
Should I try uninstalling all versions of Mocha? but then how will i get it back again?

It does work, I guess I will have to just add an extra step to my process, to render out a jpeg sequence.
In any case this is not such a bad thing, on many mocha tuts ive seen that once the designer gets to AE, they usually have thier footage in an image sequence anyway

I’m not sure I understand correctly,
I don’t think i was using mpeg in any way? Since the files from the canon eos 7d and 5d mark ii are in mov format, but compressed with h.264, where does MPEG come in?
(excuse my ignorance)