Can't get world center to track with search

This is the 3rd project I’m trying to do a very simple track, and Mocha isn’t performing the way I expect.

The clip is a hand moving past a sewing needle. I want the emitter to follow the hand moving past the needle, which I will then use in Particle Illusion to emit some blood at the point of the track. (yeah, I know… gross… but it’s an R&D thing for proof-of-concept).

  1. I add the Particle Illusion effect
  2. I set it to world emitter (I tried this with "effect emitter but had equally poor results) where it tracked the search are but my center tracking data didn’t “stock”
  3. Launch Mocha tracking.
  4. Most of it tracked OK but it stopped towards the end. I manually adjusted the track.
  5. Although the search-are adjustments “stick”, the world-center doesn’t move with it. If I manually move the world-center, it messes up the rest of the results since it appears the center is relative to the search area and the manual adjustments aren’t being saved as keyframe-specific.

Here’s a very short video (no narration or music this time) showing my experience. Would appreciate any guidance on how to get this working right.

simple track manual change sample

I used to be able to make manual adjustments without any difficulties, but things not to be working recently with even the simplest of tweaks like this. HELP?!

I’m not overly experienced with Mocha, but it is a planar tracker, which means that you’ll want to find a “plane” to track. Use “World” when the camera is moving (as it is here), “Emitter” when the camera is locked and the emitter is the only thing that will move with the track, and “World + Emitter” when both happen.

You want the “World” search area to be on a plane, like part of the sewing machine, or the wall. The “Emitter” search area should be on the thing that’s moving separate from the camera. If it’s the hand then you’ll want to find a smaller part of the hand – like the finger – that is in one plane.

Note that after you have a good track you can go back into Mocha and adjust World Center and/or Emitter Center as much as you want without having to track again.

Hope that helps.

Looking at your video, another thing to note is that keyframing your layer shape in Mocha by default does not keyframe the actual tracking data.

The blue crosshair represents the track data and you will find that you can keyframe and move the search area all over the place, but this does not move the center point.

If you wish to manually offset and animate after tracking, there are 2 ways to do this. One is to leave the Mocha interface and keyframe the offset back in the plug-in interface. The other option is inside Mocha under the track tab, you can set to “manual track”. Note: you need to be in Classic workspace view, not essentials. When you enable manual track it exposes all the tracking data keyframes and you have an override to make manual tweaks. Also note that I only recomend using this in extreme examples. Typically when a track is lost, your best bet is to stop, go back a few frames and readjust the shape to be more focused on good data and then retrack.

I hope these tips help.

Awesome info. I see the “Manual Track” option. I played with it and see the keyframes, but wasn’t able to have stellar time getting this track to work well tweaking a few keyframes. Pink dashed line jumped in (with no adjustment points) and the track never picked up afterwards.

So… working on yet another “simple track” now, and cannot get Mocha to track a hand without glitzing out on me. Any tips on this one? I feel this must be simple and I’m missing something fundamental. Why is it losing track, and when I try adjusting the search area, why isn’t it happy with my correction (or throwing off other things in the process)??

New video link attached:

To move forward on my project, I followed your 2nd tip and manually followed the motion in my NLE by keyframing the “Emitter Offset”… the end-result is the same, just took me 15x longer than if Mocha were able to perform the tracking for me (that’s why it’s there, ya?)

Tips? Tricks? Surely this is something Mocha ought to be able to do without the track glitzing out… ??

Looking at that second video, my guess is that the search area is not a true plane and Mocha is designed to track planes. The search area includes both the “side” of her thumb and parts of her palm but those are not really on the same plane so as the hand shifts it is throwing off the track. See if you can limit the search are to surfaces that are only on the same flat plane and not overlapping multiple planes (like the side vs the palm of the hand.)

Cheers,
Jason

Hey @RedRob did you get anywhere with this? I know it’s been 3 months but I ran across this thread while looking for something else and it rang big bells for me. The Boris team has helped me with some similar tracking recently and if you’re still wanting a solution, I’ve got some tips I can relay from them that might make this work at least a little better