Can't launch PI

Hi, I can’t launch PI in Vegas build 370, Adobe AE or the standalone version, it loads the screen & as soon as the emitter libraries have loaded it closes?
Windows 10, Nvidia Studio driver 531.41

This is a little weird, but see if it stops PI crashing:

  1. Launch PI
  2. As soon as the UI shows, click the play/stop button underneath the preview so it shows the play button (meaning that preview has been stopped)

You need to do that before it finishes loading your emitter libraries.

If PI doesn’t crash:
3. click the “Help” menu and select “View Log File”.
4. Then in the log file look at which emitter library it is loading at startup.

There could be a problem with that library, or maybe there’s something about the selected emitter that is causing the crash.

  1. Select a different emitter and/or library
  2. Start up the preview again.

If after step 2 PI still crashes:

  • Launch PI again, and hold down the SHIFT key ASAP (before PI UI displays) and keep holding it.

You should see a message saying that PI prefs were reset. (This should stop it from crashing)


Thanks a lot, first option worked on all, Vegas, AE & standalone :man_shrugging:

  • Launch PI
  • As soon as the UI shows, click the play/stop button underneath the preview so it shows the play button (meaning that preview has been stopped)

So was there something wrong with that library?

Or could you just hit “play” after everything was up and it worked fine?

Hi, I hit play as you suggested & it all worked as it should, I don’t know what was wrong with it,
I had already cleaned & restarted the PC but that hadn’t fixed it,
I did make a copy of the Log file when it was broken from the controls in the host, both AE & Vegas looked the same but I don’t think it tells you anything useful :man_shrugging:

pi (1.9 MB)

Is this an ongoing issue for you? (Have you seen it before?)

Does it still happen if you don’t stop the preview playback at startup, or is everything fine now?

Nope this is the first time, I very rarely if at all get problems with PI,
yep everything’s fine now, PC has been off all night, I’ve opened PI in AE, Standalone & Vegas with no problems,
I can’t explain, I don’t move any of these important files, all i can think is somewhere along the line a command of some kind got lost, Vegas crashes a fair bit esp when fx’s are added, or the fx just becomes unusable :man_shrugging:

Hi, I’m really struggling to get or keep PI open, either it closes almost immediately or when I type in the emitter search box, same error msg as above.
Windows & Nvidia have just updated but PI has been crashing all night,
I’ve tried the Play/Stop option that seemed to work before but not now,
I cleared Vegas AppData folder but that was before the updates,
I’ll keep in touch but I did manage to get the Log file if that can tell you anything.
Thanks. (128 Bytes)

And you’ve rebooted the machine?

Yes restarted it.
I’ll get back to you because when Windows & Nvidia update at the same time it can affect the pc before & after actually installing those updates,:exploding_head:
I need to open & close a few things & see if it settles down,

For reference, that “communication error” message just means that the PI app crashed, and the host can’t communicate with it anymore (of course because it’s no longer running).

So it really all comes down to why PI is crashing.

That log file was empty.

Oh sorry , I’ll try again

log (642.8 KB)

If you stop the preview (as before), does that seem to prevent the problem? (Does it always seem to involve the preview?)

I see you went back to 2022.5 for a bit (I hate reading the logs from anything before 2023 because it puts a lot of repetitive object map info in there!) but that didn’t make a difference?

I really think it has something to do with the library at startup… I see you have a custom library for many of the crashes, but then you switch to _Sampler and still had the issue.

(I can see when it crashes because you don’t see the “Exiting” lines)

Thanks, annoyingly it’s been a bit random, the crashes are either as the emitters are loading while it is opening or it would almost launch then close before the main window was even up. but the main one is - while it’s launching i do the Play/Stop thing to stop it crashing, but then it crashes when I search Pixie Dust, earlier I was seeing if I could help someone out in another post, they were using Pixie Dust, so whether that link got broken somehow, …,

I haven’t intentionally gone back to 2022.5, both the standalone & plugin show 2023 in the About, but that does bring up a thought,
the last time i opened PI was from Optics, & I made this post about libraries, Optic PI Library problem - #2 by Gid.Joiner
(looking at the log file i have opened it since that post about Optics, sorry I was wrong)

This is later this evening –
I tried opening PI, then clicking the Play/Stop button while it’s loading I can get it to launch without crashing, I then searched for Pixie Dust, instant crash everytime on ‘pix…’
so i tried opening PI - Play/Stop - but then search for other emitters, those searches didn’t crash & after searching for a few of them I was then able to put in ‘pix…’ & successfully find Pixie Dust…

At the moment it’s behaving itself :grin::man_shrugging:

Thanks for looking into this :+1:

Spoke too soon, I’ll clean my pc again & see if I can narrow it down,
(I removed the Pixie Dust from the timeline, it made no difference, it still crashed searching ‘pix…’