Centos 7 support

Trying to install mochaproFL-5.0.0-12190.x86_64.rpm under CentOS 7.2 fails with multiple dependencies. CentOS 7.2 is quickly becoming the standard linux install, and all Flame machines will be required to run this in less than a year.

 

[root@zombie 5.0.0]# rpm -Uvh mochaproFL-5.0.0-12190.x86_64.rpm

error: Failed dependencies:

libdb-4.3.so()(64bit) is needed by mochaproFL-5.0.0-12190.x86_64

libgdbm.so.2()(64bit) is needed by mochaproFL-5.0.0-12190.x86_64

libreadline.so.5()(64bit) is needed by mochaproFL-5.0.0-12190.x86_64

We have seen this problem before. The missing packages are available for CentOS 6 and most install cleanly on 7. You likely need the following packages:


http://rpm.pbone.net/index.php3/stat/4/idpl/27823352/dir/centos_6/com/compat-db43-4.3.29-15.el6.x86_64.rpm.html
http://rpm.pbone.net/index.php3/stat/4/idpl/27823382/dir/centos_6/com/compat-readline5-5.2-17.1.el6.x86_64.rpm.html
http://rpm.pbone.net/index.php3/stat/4/idpl/28608305/dir/centos_6/com/gdbm-1.8.0-38.el6.x86_64.rpm.html

The first two packages installed cleanly for us on a fresh install of CentOS 7. The last one doesn’t but after examining the package contents it looks safe to install alongside the current version of gdbm with rpm -ivh --force. Whether this is sustainable depends on your setup - you might need to add an exclude to your yum.conf to stop the package being upgraded.

With these three packages installed, we were then able to install mocha Pro. On our clean install we then ran into a series of missing library errors, each of which was easy to resolve with yum provides. On a system already running other VFX software, I suspect most will already be available, but you might need to yum install libpng12 if mocha complains about this.

Hopefully these steps will allow you get up and running. I’m sorry this isn’t more straightforward. We will be looking to add CentOS 7 to our list of supported platforms during the current release cycle.

Please let me know if you are able to get mocha running on your system, I’m happy to help troubleshoot if any problems remain if you email me at maryp@imagneersystems.com.

Actually, we just tried this on a fresh install and it worked:


We installed mocha Pro, either the node-locked or FL variant can be installed with the command:
sudo rpm -Uvh --nodeps mochapro-5.0.0....rpm
No other package installation is necessary, the software works perfectly.
License Manager does have an undeclared dependency that needs to be resolved. To install it:
sudo rpm -Uvh LicenseManager-1.4.0...rpm
sudo yum install redhat-lsb-core