Changing shape of area

Hello everyone

Particle illusion is such a great soft !

Could anyone please help me on a little question.

I want to make snow emitted inside a circle area.
For the moment all i have is the rectangle area. If I change it to
circle, the particles are emitted only from the lines of the circle but
not the whole area.
How can I change this please ?

Best
Gregoire

Circle and Ellipse emitters have always emitted from the edges only. We’re planning on adding the ability to emit from the center in the future.

An easy workaround: switch your project to 3D and make the emitter a “Sphere” instead of circle.

If you really must use a circle instead of a sphere and are using the plugin version of PI (rather than the free standalone version) you can make the emitter an “Area” (rectangle), apply it to a layer in your host that contains a circle mask (something that has zero alpha value where you don’t want particles to be created), then set the particle alpha gradient option to “alpha from layer”.

Personally I’d try “sphere” first. :slight_smile:

Alan.

Thank you very much, this helps a lot.

Hi Alan
I replied too fast. This hasn’t solved the problem.
The snow is still emitted from the edges of the circle and not the whole surface. Very annoying.
I have a video to make with a snow globe. I am stuck in this problem since 3 days…
Best
Gregoire

Do you have the option for “Sphere” for emitter shape? If not, and you are already in 3D mode, you’re probably not using the latest version (2021.5).