Clip cannot be converted to an 8 bit matte error

Hi,
I am trying to use a b & w image sequence as a hold out but keep getting “Clip cannot be converted to 8 bit to use as a matte”

So I created a new layer, added via IMPORT MATTE drop down, my B & W image sequence or mov.
Either one gives me the same error.

What’s up with this?
Thanks,

1 Like

Try making sure they are 8-Bit, RGB, tiff, jpegs, or PNGs and see if that fixes this for you.

Hi Mary,
Yeah I originally rendered it in Nuke. Then I re-rendered the sequence in AE via Jpeg sequence.
As soon as I try to import it into the Clip Matte Import in Mocha, I get the same error.
So just to clarify,
1 I created a new layer by drawing a random mask. (don’t know any other way to create a blank layer unless I draw mask)
2. under the drop down Clip Matte, I imported my 4K sequence B & W jpeg sequence.

  1. Get error "Clip cannot be converted to 8 bit greyscale for use as a matter clip "

Very frustrating :frowning:

1 Like

That’s super frustrating, I agree. Can you send me a sample frame to mary p at boris fx dot com?

Cheers,
Mary

Ok great.
Here is the clip which btw is 1……. of 7 different versions that failed in Mocha.
I’ve tried:
Rendering in nuke / quicktime/ animation/ png/ 256 grey scale
Also tried several formats in AE.
usp=sharinghttps://drive.google.com/file/d/15HCUNAiU-tAFWUC2bsL2N4gbSCcVKC1-/view?usp=sharing
Thanks

1 Like

Well, I have good news and bad news. The good news is that I can repeat your issue, so I am talking to the dev team to see what can be done. The bad news is that it is looking like a bug. Stand by please while we get to the bottom of this.

Also, what is that matte pulled from? Fog? Fire? It’s wildly variant from frame to frame.

Cheers,
Mary

Hi Mary,
Ah, great I thought It was just me.(although I am stuck at this point)
So yes the matte was made from a luma key of flames. I have to track a “hand held shaky” shot which has large flames in the foreground. I am attempting to try a holdout of the flames with the hope that I can a track of the background. Currently, I am not able to track more than 4 frames before it goes way off.

This will be the 1st time I’ve never been able to get tracking data from a shot. I tried tracking it in Manual Track, using traditional animation keyframing, but due to the hand held movement, it needs to have a keyframe on EVERY frame. So far, it is not working well. :frowning:

Thanks!

I am checking with our dev team on this one. However, you might try tracking the area without holdouts. Since it is fire, it might be so erratic that mocha doesn’t look at the fire.

So, the short answer on this is yes: it is indeed a bug and we need to fix it.

You can work around this by converting the frames to proper Grey format.

This is actually more difficult to achieve than you may think however. There is no way to render a grey image depth in After Effects that I can see (even though the option is available) and doing it via Photoshop video only renders one frame across the sequence!

If I find a solution for converting the footage to true grey i’ll let you know. In the meantime we’ll file a bug report.

Hi Martin,
We it’s disappointing to hear that, however, are you sure its a “bug”? We have 2 versions over here and BOTH give the same results. Perhaps the word should be “defect”. In any case, going into photoshop would be defeating the original cause, so I will have to find another method for now.
Thanks for all of the help, looking forward for the next update!

We use the terms interchangeably. A bug is a defect. :slight_smile:

And yes, it sure is disappointing. I do not like finding defects. :sob:

Btw, we’re about to release a v6.0.1 maintenance update, so i’ll be sure to schedule a fix for this in v6.0.2.

Cool, looking forward to use imported holdouts.
BTW, since Mocha render’s out mattes and 8 bit greyscales, is there a way to render out a video file in mocha?
Meaning, to import the holdout clip into mocha, then making mocha render out shape layers, but using the entire image. This way mocha can do the converting. NO? just spit balling here.

Sadly it’s not that simple. Only matte clips generated from layers can saved out as greyscale.

Is there any resolution or patch on this issue? i am also unable to import any matte clip that i have generated, ill try to make one in nuke. Do you have a list of variables that Mocha is looking for to authenticate a greyscale matte?

Is it looking for pixel data in alpha channel only? or RGB?

We are looking into addressing the matte conversion issue for update 2019 v6.0.2.
I’ll have to confirm with the dev team a proper workaround in the meantime and get back to you.

Just letting you all know we’ve identified and fixed the problem. It will be available in the next update.

1 Like

Thanks Martin!

Ah that sounds great, looking forward to the next release.
Btw, While you’re at it, see it you can throw in a bug fix to the following issue :slight_smile:

Bug or feature limit?
So if I use the mocha logo (insert clip) and lower the opacity(Insert tab ) to say 7% so the logo is barely visible.
Then duplicate that layer.

RESULTS:The layer’s opacity goes back to 100% for both original layer & Duplicated layer. (I was expecting to have 2 layers at 7 % opacity)
This gets annoying because I have to always re adjust the opacity on both layers.

Bug or no bug?

Thanks!

Mocha Pro 2019 v6.0.2 is now out and the Matte Clip issue is resolved in this release:

1 Like