Constant "Failed to restore object state" errors in 2019


#1

I just upgraded to 2019 on macOS Sierra 10.12.6. I am constantly getting random “Failed to restore object state” when working on rotos. I’m basically losing work every time it happens.

When the error occurs, all my roto data gets unusably distorted (shifted up and away from the original location, and also scaled/skewed). Undo’ing, nor does restarting Mocha and reloading the project does not allow me to get my original roto data back to its original state.

I’m not doing anything particularly complicated…just rotoing a spline linked to previously tracked data on another layer.

Needless to say, this is VERY frustrating.


#2

Hi Mel,

Can you send us a project file so we can see this in action, or direct reproducible steps so we can try to reproduce it? We believe this issue is resolved in the upcoming maintenance release, but we want to be sure.


#3

Hi Martin,

I’m in the middle of a deadline now, so I’ve reverted back to Mocha Pro 5, which is working fine. I’ll see if I can follow up with this as soon as I get some free time.


#4

For what it’s worth, the I think the issue seems to occur mostly when I try to undo a mask point manipulation.


#5

Ok, and did you use the magnetic tool anywhere along the way, or was it all just standard x-spline pen tool?


#6

As a matter of fact, I did use the magnetic spline tool on the shot in question!


#7

Okay, that is probably the reason. This will be fixed in the upcoming maintenance release!!


#8

Hi all, if you haven’t already, try the new maintenance release that came out last week (Mocha Pro 2019 v6.0.1). This should resolve your problem.