Copied data from txt file does not past into AE

Hi, I am hoping someone can help as I can not get this to work.

  1. I have tracked my footage in Mocha
  2. Exported the tracking data as after effects transform data.
  3. Copied all data from the txt file
  4. In AE (CS4) in my compostion I have the layer selected I wish to stabilise selected and can not past that data into that layer. Under Edit the past is geyed out.

Thanks Shawn

—Quote (Originally by ross_shain)—
Shawn,
You can also try saving the data to a .txt file out of mocha. Open that file in text editor, copy then paste to AE.

Are you running Vista 64 bit? Unfortunately Adobe has some issues when pasting into AE from any app on that OS.

-Ross
—End Quote—
I’ve been using Mocha AE V2 & shape 1.02 under Vista x64 for awhile now and as you noted, it is somewhat erratic. But what’s happening specifically with Mocha Shape is that when you paste into AE CS4 from Mocha, the values are being truncated at the 1st decimal place in AE. It’s possible that it’s only a display problem with the Shape plug-in (no more than one decimal place is displayed for any item, no matter what you type in), but I tend to think not, because the cutout is affected by larger movements, but anything that is in the 2nd decimal place or more doesn’t have any effect.

It doesn’t matter whether you paste from Mocha directly or save the file and copy/paste it from notepad, etc. The shape moves around correctly when previewed in Mocha and the values in the text file look correct (5 decimal places). But even manually typing the values in AE for a few key frames doesn’t work and they are truncated to one decimal place in AE.

Is there any way around this?

—Quote (Originally by MatthewM)—
I don’t fully understand the problem you are describing. Do you mean that the translation values exported from Mocha are different if the original clip is a Cineform AVI or MOV file, or that the translation values are always the same but they behave differently in After Effects depending on whether the clip is Cineform?
—End Quote—
Its only a problem with Cineform MOV and AVI files and the actual translation values (as displayed in Mocha or as viewed in Notepad) are 1/100 of the correct values only with Cineform files. Uncompressed AVI works fine. When Mocha Shape didn’t work with Cineform, I started adding simple expressions to each property in AE, just to see what would happen. Only Translate X & Y were wrong. The clips that I had trouble with, are 1440x1080 (1.333 PAR) 30p (not 60i) files, so I made sure that the setting for frames vs. fields was set correctly in Mocha. I also made sure that the frame rate was 29.97, because sometimes I forget and I leave it at the “default” value of 10 fps.

Maybe today, I’ll try it again using a Cineform file converted to 1920X1080 (1.000 PAR), since that’s all I’ve used to date with Mocha tracking and pin data. This is the first time that I tried Cineform and Mocha Shape. I am using the most recent versions of AE CS4, Mocha 2 and Mocha Shape under Vista x64.

The Cineform clips that I am using are progressive (30p), not interlaced. They have the correct dimensions in Mocha (1440x1080) and the correct PAR (1.333). The clip dimensions are recognized as HDV in Mocha, but changing the setting to Custom and specifying the PAR=1.333 makes no difference. In AE, the comp setting is Custom and it is also 1440x1080, PAR=1.333.

The actual AE expression multiplier needed for Translate X and Translate Y to get perfect tracking of the shape in AE, is slightly less than 100. Maybe some of the significant digits are being truncated in AE.

I haven’t had a chance to try full HD Cineform clips yet with Mocha Shape, but I will do as soon as possible. Thanks for your help. Mocha is an impressive piece of software and this is the first time that I have had any trouble with it.

—Quote (Originally by jabloomf1230)—
It appears to be a bug in the interpretation of Cineform avi and mov files, as converting the file to uncompressed works just fine.
—End Quote—
I don’t fully understand the problem you are describing. Do you mean that the translation values exported from Mocha are different if the original clip is a Cineform AVI or MOV file, or that the translation values are always the same but they behave differently in After Effects depending on whether the clip is Cineform?

Shawn,
You can also try saving the data to a .txt file out of mocha. Open that file in text editor, copy then paste to AE.

Are you running Vista 64 bit? Unfortunately Adobe has some issues when pasting into AE from any app on that OS.

-Ross

A few things to add here. If you footage has a PAR of 1.33, be sure to set this in mocha clip settings. You do have to go to custom to set this. I believe a new build will address this shortly.

Secondly, if you are de-interlacing in mocha, you will need to de-interlace your AE project for the shape data to line up properly.

Here is my method for this
Note: only to use when source footage is shot on video and you need to de-interlace to get a good roto. You can substitute PAL frame rates as well.

n mocha:

  1. import footage. Set the frame rate to 59.94 and the project setting to de-interlace.
  2. Do your track/roto work
  3. Export your shape data

In After Effects:

  1. interpret AE footage as interlaced
  2. set up AE comp NTSC, 59.94 fps and drag the clip to comp > this emulates the double length comp we like we do in mocha: every field is now on a progressive frame
  3. select desired layer and paste mocha shape data
  4. Finish your composite, then drag that comp to a NTSC 29.97 comp to render

Hope this is useful,
R

—Quote (Originally by jabloomf1230)—
Its only a problem with Cineform MOV and AVI files and the actual translation values (as displayed in Mocha or as viewed in Notepad) are 1/100 of the correct values only with Cineform files. Uncompressed AVI works fine. When Mocha Shape didn’t work with Cineform, I started adding simple expressions to each property in AE, just to see what would happen. Only Translate X & Y were wrong. The clips that I had trouble with, are 1440x1080 (1.333 PAR) 30p (not 60i) files, so I made sure that the setting for frames vs. fields was set correctly in Mocha. I also made sure that the frame rate was 29.97, because sometimes I forget and I leave it at the “default” value of 10 fps.

Maybe today, I’ll try it again using a Cineform file converted to 1920X1080 (1.000 PAR), since that’s all I’ve used to date with Mocha tracking and pin data. This is the first time that I tried Cineform and Mocha Shape. I am using the most recent versions of AE CS4, Mocha 2 and Mocha Shape under Vista x64.
—End Quote—

Hi Ross
Running xp professional. I have rebooted AE and now all of a sudden it is working. The machine must be faulty. Thanks for your reply
Shawn