Crash when trying to install Particle Illusion Standalone on Mac

When I try to install this program on my Mac Pro with macOS Catalin ver 10.15.5 I get this message:

The “Particle Illusion Standalone 2020.5” install encountered an error.
An error occurred in a program run by this package, which may cause installation to fail. Please contact the software manufacturer for assistance.

Then the computer hangs so I have to use “Force Quit” to interrupt the installation. I have the same problem when trying to install “Particle Library”.

I need help!

Regards
Christer

Hello,

I tested this on my Trashcan Mac Pro that has OS Catalina 10.15.5 & could not repro the problem. Both installers ran fine & installed the products.

You may either want to retry downloading or make sure you have Admin privilege or not use any third party unzip utilities though, for me,
these are downloaded as dmg files & not compressed.

Thanks.

  • Mukesh Shah
    BorisFX/QA

Have you tried restarting your Mac and then installing?

Sometimes weird issues like this are only fixed by a restart.

Hello again,

I removed the installation file “Particle Illusion 2020.5 Standalone.dmg” from my system and downloaded it again (2 times), made a virus check, restarted my computer all with the same bad result.

The error occurs after this step in the installation

Pic 1

and befor this

Pic 2

Then I have to go to Force Quit and break the installer to use my computer again.

Pic 3

/Christer

While the installer is still open (before it crashes), open the log (Cmd+L), and switch it to “Show Errors and Progress”.
You can then click the “Save” button on the right, or just select the last few lines of the text, copy and paste it here.

Hello agin Alan, and thank you for helping me with this issue. Here is the log just before the chrash.

Installer Log 27-Jun-2020.txt (2.3 KB)

/Christer

Hello again Alan,
Maybe the attached file in my last reply could no be opened so I paste the contents here instead:

Jun 27 12:29:46 MacPro Installer[2425]: @(#)PROGRAM:Install PROJECT:Install-1000
Jun 27 12:29:46 MacPro Installer[2425]: @(#)PROGRAM:Installer PROJECT:Installer-965.1
Jun 27 12:29:46 MacPro Installer[2425]: Hardware: MacPro6,1 @ 3.00 GHz (x 16), 65536 MB RAM
Jun 27 12:29:46 MacPro Installer[2425]: Running OS Build: Mac OS X 10.15.5 (19F101)
Jun 27 12:29:46 MacPro Installer[2425]: Env: USER=christerkyllergard
Jun 27 12:29:46 MacPro Installer[2425]: Env: COMMAND_MODE=unix2003
Jun 27 12:29:46 MacPro Installer[2425]: Env: PATH=/usr/bin:/bin:/usr/sbin:/sbin
Jun 27 12:29:46 MacPro Installer[2425]: Env: LOGNAME=christerkyllergard
Jun 27 12:29:46 MacPro Installer[2425]: Env: SSH_AUTH_SOCK=/private/tmp/com.apple.launchd.70pEeS1C22/Listeners
Jun 27 12:29:46 MacPro Installer[2425]: Env: HOME=/Users/christerkyllergard
Jun 27 12:29:46 MacPro Installer[2425]: Env: SHELL=/bin/bash
Jun 27 12:29:46 MacPro Installer[2425]: Env: TMPDIR=/var/folders/c5/b6s5jf4935v0n6k8kh3nv71c0000gn/T/
Jun 27 12:29:46 MacPro Installer[2425]: Env: __CF_USER_TEXT_ENCODING=0x1F5:0x0:0x0
Jun 27 12:29:46 MacPro Installer[2425]: Env: XPC_SERVICE_NAME=com.apple.xpc.launchd.oneshot.0x10000006.Installer
Jun 27 12:29:46 MacPro Installer[2425]: Env: XPC_FLAGS=0x0
Jun 27 12:29:46 MacPro Installer[2425]: Particle Illusion Standalone 2020.5 Installation Log
Jun 27 12:29:46 MacPro Installer[2425]: Opened from: /Volumes/Particle_Illusion_2020.5_Standalone/Particle Illusion 2020.5 Standalone Installer.pkg
Jun 27 12:29:46 MacPro Installer[2425]: Package Authoring Error: has an unsupported MIME type: image/data
Jun 27 12:29:46 MacPro Installer[2425]: Package Authoring Error: <background_scaling> has an unsupported MIME type: X-NSObject/NSNumber
Jun 27 12:29:46 MacPro Installer[2425]: Package Authoring Error: <background_alignment> has an unsupported MIME type: X-NSObject/NSNumber
Jun 27 12:29:46 MacPro Installer[2425]: Package Authoring Error: has an unsupported MIME type: X-NSObject/NSNumber
Jun 27 12:29:47 MacPro Installer[2425]: Product archive /Volumes/Particle_Illusion_2020.5_Standalone/Particle Illusion 2020.5 Standalone Installer.pkg trustLevel=350
Jun 27 12:29:47 MacPro Installer[2425]: External component packages (5) trustLevel=350
Jun 27 12:29:54 MacPro Installer[2425]: Could not load resource readme: (null)

Regards,
Christer

Is it not anyone in this forum who can help me with this problem? As this software is free, Boris support does not want to help but refers to this forum. This makes me doubt the Boris FX products as it is their installer that crashes.
/Christer

Hi Christer,

We’ve been trying to understand the problem, which apparently is only affecting your system. The software has been installed by thousands of users and we have to date only had a very small handful of users encounter an issue with the installer.

On one system it was anti-virus software that was wrongly identifying the installer as malware but that problem was resolved by using a different anti-virus program. You state above that you’re running an anti-virus program on the installer - perhaps anti-virus software on your system that might be incorrectly flagging the product and causing the problem? Have you tried running the installer without first running an anti-virus on it? Maybe you can disable the anti-virus program before running the installer. Have you seen this problem with any other product installers on your system?

Thanks,
Peter.

Hello again,
I have tried to completely shut down my virus program, cleaned the computer from various junk, restarted the computer with the same result.

I have no other problems or oddities with my computer and have never had anything like this before. Other programs are installed as usual.

To test if there was anything special about Boris FX’s installation program, I tried to install an old software from Boris FX that I no longer use, and it went without problems, see picture.

A more detailed description of the origin of the problem is:

  1. I downloaded the program from this page

  2. I installed the program and it went well. According to the information on Boris FX’s website, a link to the Emitter Library would appear. According to the text, it was important to follow this link, but it never appeared when I started the program.

I then looked up a link to the Emitter Library and downloaded the library and tried to install it. Then I got the same error message as the one I showed for the main program.

  1. I thought then that I might have downloaded the wrong version of the software (free or paid version?) So I uninstalled the main program (which then worked) and deleted both files. Then I downloaded the main program again and tried to install it and now the main program could not be installed and that is the situation now.

/Christer

Hello Christer,

At this stage, I’d suggest opening a case with tech support to see if they can assist They might need to tunnel into your system to grasp a full understanding of the problem and hopefully they’'ll be able to install the application for you.

Have you ever had similar issues when attempting to install other software, such as Adobe After Effects or Premiere Pro?

Thanks,
Peter.

Hello Peter,
No, I have never experience this or similar problems before.

I am not using Adobe or Premiere software but I have been using Avid Media Composer and Edius before, but now I use only DaVinci Resolve since some years ago for video editing.

With Media Composer and Resolve I have been using Boris Continuum plug-ins all without problems. I also use Wolfram Mathematica, a fairly big software package, without any problems with the installation.

I welcome if someone can dig deaper into this problem.
Regards,
Chriser

Since my last post in this forum, I have installed a new version of DaVinci Resolve and a new version of MacOS without any problems.

I then tried again to install Particle Illusion but unfortunately with the same error message as before.

You said in your post that this matter should be taken to tech support. Can I do that?

When I previously turned to them, I was referred to this forum as it is a free software.

Regards,
Christer

I wonder if it’s a language issue – perhaps the problem only occurs when macOS is set to a language other than English?

My macOS is set to English.
I only have things like date settings and keyboard set to Swedish.

Same trouble for me. I can install Particle Illusion for Mac (Standalone last version) on Catalina 10.15.6 but the Continuum 2020 Particle Emitters crashed every single time I tried to install it.

Anybody seeing a crash when installing on Mac, please do the following:

  1. Launch the installer
  2. Use Cmd+L to open the Installer log window before you start the install
  3. Switch it to display all logs
  4. Start a screen recording (using QuickTime Player or other)
  5. Start the Install, making sure that the log window is visible and tall enough to show several lines of text at once.

After it crashes you can stop the screen recording, upload it somewhere and DM me the link.

Thanks!

Thank you. That should be very helpful!

Hello again. So it is not only me having this problem.
Here is my copy of the Installer Log.

Particle crash.pdf (555.5 KB)

/Christer