Crash with Insert-Tool with Mocha Pro and Media Composer

I am using Mocha Pro 2021 8.0.3 build 19 with Media Composer 2021.6 on a windows PC (2020 H2). I have a severe problem with the insert-tool. Within MC it does not render.

In detail: I have a moving car, and I want to change the license plate (for an exercise only!). Within MC the clip (transcoded to DNxHR SQ, no other effects) is on V2 and a static picture is in V1. Within Mocha I created a shape and surface and tracked it. I can now insert the mocha logo of something else on the license plate. Within Mocha that works fine with the logo and with the picture in V1. The car passes by and everything is ok. Save and quit.

Back to MC: Module Renders: Insert Composite, Insert layer None (or first belo). Now I can see the Mocha logo. I can go forward and backwards. Everything is ok. Now I hit the render button and rendering starts. Still I can see the Logo. When the rendering (takes one minute) has finished, the logo has disappeared.

Even worse with V1 instead of the logo: When trying to render, MC prepares a crash report and I have to kill MC.

Other modules (stabilize, remove) work fine, and so I think Mocha has a problem.

Klaus-Dieter

Hi there,

Can you try turning off GPU processing under Mocha Preferences and seeing if this solves your issue? I just want to make sure this isn’t the conflict. Please let me know and we will troubleshoot this further.

If you are on a deadline and the Insert Renders and looks fine inside Mocha Pro, then you could try exporting out of Mocha and relinking the rendered clip back into Media Composer.

In Mocha, go to File>Export Rendered Clip.

Otherwise - more details can help the team. Is the project interlaced?

Hi Mary,
I switched GPU prossesing off, closed Mocha and MC and restarted the host (MC). Nothing changed.

Hi Ross,
I do not have a deadline. It is just a test. Although using BCC for four years and Mocha for two years I am following your (excellent) training series Mocha Essentials. I did some exercises with multiple shapes, track mattes and adjustingtracks. That is why I am trying to exchange the license plate. :slight_smile:

It is an UHD-project (3840 x 2160) 25 fps progressive project.

But your suggestion to render the clip inside of Mocha led to another interesting fact that might help: Mocha rendered the clip as long as parts of the planar surface are within the clip. When the planar surface is outside of the clip Mocha stops rendering (Frame xx not rendered in clip ‘Composite_Input’). What did I make wrong?

Next test: in MC I shorted the clip so that the license plate is visible for the whole time. Now Mocha renders the clip, and the clip can be exported. But MC still produces a crash report.

That is interesting, and I think we might need to loop @martinb in since the behavior changed when the object didn’t go offscreen and that flags oddly to me.

I can’t reproduce this, so I would need to see a screenshot of the problem to ascertain what is going on.

Here are 4 screenshort:
1 Tracking forward
2 Tracking forward shape and surface outside
3 Rendering
4 Rendering shape and surface outside, error

I hope that helps. What am I doing wrong?




When you click render on that frame, is that all you see?

Yes! But I saw something very strange. When I zoom out, parts of the surface tool is inside the clip. When I zoom in, the surface tool is completly outside the clip. When I click “Render”, than I get this error message.



Are you able to send me the Mocha project? You can export it from the File menu.

Hi,
here is the project file.
Nummernschild.mocha (448.0 KB)

Hi,
any suggestions?

Let me re-tag @Martinb so we make sure he sees this.

Thanks for the reproduction project. Sorry for the delay on this. I have never seen Mocha do this before.
We’ll need to take it to QA and check why it wouldn’t render at all outside the bounds of the screen. It should be reverting the source clip if it can’t render the frame.

Yes, the interesting thing is, that outside the bounds of the screen, there is nothing to render. Mocha shoud keep the clip as it is.

That meens I have to wait for the answer of QA.

Hi,
still no solution after one month?

I have not heard an update on this yet. I will ask @Martinb if QA ever had any headway with this.

Hi, sorry, I thought we’d responded.

We’ve identified the problem and fixed it. The fix will be in the next release.

In the meantime, if you want to keep the render working, you need to keep a portion of the surface on the screen. It can be masked out so it doesn’t affect the final result.

Thanks, Martin!