Crash with lens calibration in Mocha Pro After f/x plug in

Using the current version of After F/X (18.1) and Mocha pro 2021 After F/X Plug-in. Mac OS 11.3.

Working my way though some of the Mocha Pro training modules (18c) and when I try to use the calibration grid and use the locate lines command, the plug-in crashes but safely returns me to After F/X. I tried the same file with the stand alone version of Mocha Pro and it works fine. Is there something I need to do to make the MochaPro plug-in happier? Is this a known bug? None of the above? I guess this would be a possible bug report, but I’m not sure.

Keith Sanborn

Hey Keith,

A crash is never a good thing, but let’s see if we can narrow it down:

  • Are you using the training footage or your own? What are the dimensions and format?
  • What line length are you using to locate lines?
  • Can you show me your current GPU settings in the Mocha Plugin Preferences?

Hi Martin,

Thanks so much for getting back to me. I was using the footage supplied with the exercise in 18c. I’m not sure what the original line length was, but when I opened it again, it was 549. Thinking that might be too much, since you brought my attention to it, I tried 71. Same result: Mocha Pro plug-in crashed and I was safely returned to After F/X.

Here are the GPU settings for After F/X:

Fast Draft: Available
Texture Memory: 1632.00 MB
OpenGL
Vendor: ATI Technologies Inc.
Device: AMD Radeon Pro WX 9100 OpenGL Engine
Version: 2.1 ATI-4.4.17
Total Memory: 15.98 GB
Shader Model: -

I have 32 gigs of ram with 24 assigned to Adobe applications and generally am running nothing else.

The Mocha Pro GPU settings are as follows:

Can I up the amount of texture ram to reserve? I think I have plenty to spare.

What do you suggest?

I don’t have a deep knowledge of RAM and GPU settings. I have had to juggle settings a bit when the Mocha Pro or Silhouette plug-ins crash when I’m using them with DaVinci Resolve.

I await your wise counsel,

Keith

(Attachment PastedGraphic-1.tiff is missing)

Hi Martin,

I forgot to say, the calibration chart is 5568 × 3132. And when I tried to send you screen grabs of my settings they were rejected in spite of the fact that they were .png’s.

GPU texture alllocated was what I assume was the default 256mb. Tried upping that to 6gigs. Same result. And yes, I did exit the plug-in and return to the host then reboot the plug-in before reattempting to use the locate lines command. I did up the line length to 256.

Keith

Ok, a few things:

  1. Don’t set the “Texture RAM to reserve” in Mocha to any higher than 1024. This is only for display and doesn’t need much. In fact setting the value high can be detrimental.
  2. Define your GPU rather than setting it to Automatic. If you have more than one GPU, set it to the “Display” GPU (this will be listed in brackets).

This may not help the crash, but it will help you for future work.

You’ll need to reboot AE after these changes.

I’ll test the calibration footage locally and see if I can see any issues.

Thanks. I very much appreciate this. I will work through this and let you know if that changes things. The default setting for “texture ram” was 256MB but that still crashed. Apparently I need to send some time with that section of the manual.

Keith

Are you using a different lens calibration grid to the project files? That calibration grid is only HD.

Just using what came with it. I checked the resolution in the finder.

(Attachment PastedGraphic-1.tiff is missing)

Ah, I see what I did. But no, there isn’t a crash on my tests locally so we’ve got to narrow it down to something else.
Can you send me your mocha log from the Help menu?