Crashing with mocha pro 3.2.0

I’m getting frequent crashes in mocha pro 3.2.0 when tracking a small, low contrast area.
Admittedly, it’s a far less than perfect area to track – but crashing?

Here is the are of the crash log that I believe pertains to the crash…

Thank you in advance!

Thread 22 Crashed:
0 liblayercam.1.0.0.dylib 0x0000000100b4f6af Layercam::Contour::iControlPointIndex(Layercam::ControlPoint const*) const + 203
1 liblayercam.1.0.0.dylib 0x0000000100b51d59 Layercam::Contour::vGetControlPointXY(Layercam::ControlPoint const*, float, bool, bool, bool, float&, float&, bool&, LCAM_TrackCache*) const + 359
2 liblayercam.1.0.0.dylib 0x0000000100b5f4e7 LCAM_XSplineContour::convertToSpline(float, bool, double, bool, bool, unsigned int, unsigned int, bool, LCAM_TrackCache*, bool, bool) const + 659
3 liblayercam.1.0.0.dylib 0x0000000100b5c973 LCAM_XSplineContour::pConvertEdgeToSpline(float, bool, bool, bool, unsigned int, unsigned int, bool, LCAM_TrackCache*, bool) const + 49
4 liblayercam.1.0.0.dylib 0x0000000100bd758d LCAM_SelectionManager::computeLayerBoundingBox(unsigned int, float, bool, Gan_ImageWindow*) + 1185
5 liblayercam.1.0.0.dylib 0x0000000100bb99b6 LCAM_GarbageMatteMaker::pgiCreateMatte(LCAM_SelectionManager*, Gan_Image*, QVector<LCAM_Layer*> const&, unsigned int, unsigned int, unsigned int, IS::FrameWarp*, unsigned int, unsigned int, unsigned int, bool, bool, bool, bool, _IS_PROXY_SCALE, bool, bool) + 734
6 liblayercam.1.0.0.dylib 0x0000000100bba79d LCAM_GarbageMatteMaker::vGenerateMatte(LCAM_SelectionManager*, Gan_Image*, unsigned int, unsigned int, IS::FrameWarp*, unsigned int, unsigned int, Gan_Image const*, bool, bool, Gan_Image**, bool, bool, _IS_PROXY_SCALE, bool, bool) + 655
7 liblayercam.1.0.0.dylib 0x0000000100bd3030 LCAM_SelectionManager::spgiGetOuterGarbageMatte(unsigned int, float, bool, _IS_PROXY_SCALE, bool, bool) + 1738
8 liblayercam.1.0.0.dylib 0x0000000100ad8ea7 LCAM_PreProcManager::vCompensateForDrift(LCAM_ProgressDialog*, unsigned int, unsigned int, unsigned int, bool, LCAM_ThreadedTracker*) + 1289
9 liblayercam.1.0.0.dylib 0x0000000100ae0d6d LCAM_PreProcManager::trackLayerBetweenFrames(unsigned int, unsigned int, unsigned int) + 8805
10 liblayercam.1.0.0.dylib 0x0000000100ae2f14 LCAM_PreProcManager::trackToNextFrame(LCAM_Layer const&) + 724
11 com.imagineersystems.mochapro 0x00000001000591cc 0x100000000 + 365004
12 com.imagineersystems.mochapro 0x000000010001f9e3 boost::function0<_IS_BOOL>::operator()() const + 79
13 com.imagineersystems.mochapro 0x000000010001e6e5 0x100000000 + 124645
14 com.imagineersystems.mochapro 0x000000010001e339 0x100000000 + 123705
15 QtCore 0x00000001024e453e 0x1024c8000 + 116030
16 libsystem_c.dylib 0x00007fff92075742 _pthread_start + 327
17 libsystem_c.dylib 0x00007fff92062181 thread_start + 13

Thread 22 crashed with X86 Thread State (64-bit):
rax: 0x00000001060da600 rbx: 0x00000001060da600 rcx: 0x0000000124d857f0 rdx: 0x0000000000000001
rdi: 0x1000000000000000 rsi: 0x0000000000000006 rbp: 0x000000011889ecd0 rsp: 0x000000011889ec80
r8: 0x0000000000000000 r9: 0x0000000000000000 r10: 0x000000011889e3e0 r11: 0x000000011889e800
r12: 0x0000000111350190 r13: 0x0000000000000001 r14: 0x0000000111341220 r15: 0x0000000124d85818
rip: 0x0000000100b4f6af rfl: 0x0000000000010206 cr2: 0x0000000104206000
Logical CPU: 6

Two machines crashing here consistently with Mocha 3.2.

When I try click to RENDER button in lens module, mocha PRO crashed.

Please look for this screen shoot

http://www.gajowa.krakow.pl/images/reklamowka/mocha_error_lens_render.png

Best Regards

G.J.

Yea, restart not helping, and I use memtest to test my memory all is ok

I just got 3.2 and it is crashing all the time to remove small dots on actor’s faces. Where do I get version 3.1? It looks like 3.2 has some bug issues.

Also when I reopen when it crashes and try to save the latest Auto Save file Mocha crashes again when the file is opening.

lproduction, you can get previous versions here:
http://www.imagineersystems.com/download-legacy-view

If you can both email me the project file you are using for the shot, that will help us narrow down the issue. Please email me the mocha project file at:
martinb[at]imagineersystems.com

In the meantime, please try 3.1.1.

Hi there,

Do you get the same issue if you install mocha Pro 3.1.1? We want to determine if there is a difference in the new release.

Have you tried restarting your machine? It could be a memory issue.

Can you try to remake the file from scratch and see if it gives you the same error?

I just reinstalled 3.1.1 and it has not crashed with this shot.

Additionally, it actually ‘appears’ that 3.1.1. is having better luck with tracking the movement…

Again, this is a very, very small, low-low contrast area.

Thank you.

For what it’s worth – I’ve never had Mocha crash on me before this 3.2.0.
I use it via AE CS6. The original Mocha AE as well as the upgraded Mocha Pro (3.1.1) have been rock stable on my system with the work I’ve do.

Hi Martin,
I’ve sent the file to you and to re-confirm… It works fine in 3.1.1 but does crash consistently in 3.2 (I just checked again before sending you the project file)

Thank you!