Curve editor display issue


#1

Hello,
I’m using Mocha 2.6.2 and I’m having some issues with viewing the curves in my curve editor. I’m trying to keep a constant frame between two keys, but for some reason all the curves on the curve editor show up flat, or disappear when I select the curves and say Frame All. Selecting constant instead of linear in the options menu doesn’t seem to help much either. Any ideas?
Thanks!


#2

Can you let me know what you are trying to do in the curve editor and I can see if I can find a workaround?

Cheers,
Mary


#3

Can you let me know what you are trying to do in the curve editor and I can see if I can find a workaround?
Cheers,
Mary


#4

Ah, ok, I see. That’s exactly the kind of thing we engineered the new dope sheet for. I am glad you found a workaround in the curve editor.

Have a lovely day,
Mary


#5

Hi there,
You may be running into a bug in the curve editor, can you try adjusting points individually?
In general, one of the reasons we have phased out the curve editor and added the dope sheet to mocha V3 is because the curve editor can be so difficult to work with.
Let me know if selecting the points individually gives the same results?
Cheers,
Mary


#6

Hi there,

You may be running into a bug in the curve editor, can you try adjusting points individually?

In general, one of the reasons we have phased out the curve editor and added the dope sheet to mocha V3 is because the curve editor can be so difficult to work with.

Let me know if selecting the points individually gives the same results?

Cheers,
Mary


#7

Ah, ok, I see. That’s exactly the kind of thing we engineered the new dope sheet for. I am glad you found a workaround in the curve editor.
Have a lovely day,
Mary


#8

Hello,

I’m using Mocha 2.6.2 and I’m having some issues with viewing the curves in my curve editor. I’m trying to keep a constant frame between two keys, but for some reason all the curves on the curve editor show up flat, or disappear when I select the curves and say Frame All. Selecting constant instead of linear in the options menu doesn’t seem to help much either. Any ideas?

Thanks!


#9

Hello Mary,
I tried selecting the individual control points, but I’m still getting the same flat curve. The shape isn’t linked to a track or anything, except its own, but that doesn’t seem to affect the curves either…


#10

Hello Mary,

I tried selecting the individual control points, but I’m still getting the same flat curve. The shape isn’t linked to a track or anything, except its own, but that doesn’t seem to affect the curves either…


#11

I think I found a fix for the problem. I was able to delete the surrounding keyframes, reapply them and then select constant in the curves editor menu. The curves still aren’t updating for some reason, but it seems to work.
Thank you for your suggestions!
Side note: I needed to create a rotoscope matte and hold a keyframe on two frames that were just alike, but the shape inbetweened the frames instead.


#12

I think I found a fix for the problem. I was able to delete the surrounding keyframes, reapply them and then select constant in the curves editor menu. The curves still aren’t updating for some reason, but it seems to work.

Thank you for your suggestions!

Side note: I needed to create a rotoscope matte and hold a keyframe on two frames that were just alike, but the shape inbetweened the frames instead.