Davinci resove and particle illusion plug in

does anyone know how do i use pi pluggin in davici resolve. i can open pi but not onto my footage, it only opens by itself i.e. without my footage.

thanx

  1. Apply Particle Illusion to your clip
  2. Click the “Launch Particle Illusion” button to open the PI UI
  3. If your clip does not show in PI, check the preview setting above the stage next to the zoom level – make sure it’s set to “Composite on Source Video”

Hope this helps!

how Alan thanx for your speedy reply and taking the time to respond. The
problem is i can’t apply particle illusion to my clip. when i try to do it in
edit mode, i see particle illusion but not the open pi ui. in fusion if i connect the
pi node onto the node image i see mocha camera tracking but no pi. what i can do is
click on pi and a blank particle illusion clip appears and i can open pi with that but not
with one of my clips.

(Attachment Capture 01.wmv is missing)

here’s a clip if it helps

thanx

pi clip.mp4 (1.19 MB)

I’m not a Resolve expert, but I talked to one and it appears that you can’t apply PI to a VFX Connect clip. You can apply it to a regular clip or a compound clip, but not a VFX Connect clip.

Make sense?

i’m also new to resolve, so that should be good enough info
for me to beggin to research.

thanx alot alan

Where should I see Particle Illusion to add it to a clip?
I can’t find it anywhere

If you’ve installed the full Continuum installer to pick up the plugin version (which is different than the standalone Particle Illusion installer which runs purely as a standalone app instead of a plugin), then you should see BCC Particle Illusion in the usual effect lists in your host under the BCC Particles category. (Make sure you also install the separate supplemental Particle Illusion Particle Emitters installer so you have the full set of emitter libraries to choose from since the Continuum and the PI application installers only include the most recent emitter library.)

-Jason

Hi Jason
Resolve shows BCC_OFX.ofx.bundle
and BCC+.ofx.bundle

The file I downloaded for PI was Particle Illusion Particle Emitters
The only other option was Particle Illusion Standalone

Thanks
Pete

When you are in Resolve’s Edit pane, select BCC_OFX which brings up the list of BCC categories and filters. Scroll down to the BCC Particles category and select BCC Particle Illusion. Here is a screenshot from Resolve’s Edit pane. Note that Resolve’s other panes like the Color pane differ a bit in the details, but the basics are the same. Resolve also has search fields for helping find particular plugins in the lists.

Cheers,
Jason

Thanks Jason.
So I’m using Resolve (free version) because PI won’t work in Final Cut Pro.
I drag the Particle Illusion effect onto my clip and then select ‘Launch Particle Illusion’.
When I select to view composite over source video I still see the particles on a black background.
What am I doing wrong?
Thanks
Pete

Is the current time indicator parked over the clip with the effect when you launch PI? Perhaps you could include a screencapture showing the issue if you’re still seeing this?

Hi
I just tried to get a screenshot but now as soon as I click on ‘Launch Particle Illusion’ the program stops responding.
Is there a simple workflow documented that I could use?
Thanks

Hi
Got the PI window to open this time. Here’s the screenshot.
I don’t know how to see my original video in the PI window, for tracking, etc.

Thanks very much
Pete

Do the other preview settings in PI work? (Single frame, checkerboard) or is it always black?

If you’re on Windows, try updating your video drivers.

Sorry for the delay.
All are black except checkerboard.
I’m on a Macbook running Monteray.

What do you see if you launch the FX Browser button back in the native Resolve UI → which launches the native preset loader? Do you see the image there or is it still black. And if you pick a preset from the FX Browser and apply it do you see it render with the particles correctly over your clip?

I’m adding the effect by clicking on BCC_OFX / BCC Particle Illusion.
Then I click on Launch Particle Illusion on the right hand side of the screen.
If I click on FX Browser on the right hand side the preview is still black (no source video).
I did do a test render and the video is there, just not when I’m trying to preview it in the edit.
Screenshot 2022-08-08 at 15.03.32

Oh I see the issue. You’re applying it from the Generators group in Resolve. A generator is not applied to another clip at all. A Generator is literally a pure generator that synthesizes content from scratch, so seeing it over black is exactly what is expected for the generator version.

Take a look at your screenshot and notice there is a group called Filters above the group called Generators. Find the version of Particle Illusion in the Filters/BCC_OFX/BCC Particles group and drag that onto your clip.

-Jason

1 Like

Yes! That worked!
Thank you so much for your help.