Different layers not being recognized

I’m trying to remove an object and I have already tracked it and the background. I put the background layer below the object layer because that’s how I was told mocha recognizes which should be on top of which. But it’s not showing any signs of recognizing this. The mattes dont change color when I select the background, if I try to track the second background layer (the ground) then the object interferes with the tracking.

What am I doing wrong? I followed the steps of the REMOVE BASICS video tutorial.

To make sure they are matting correctly, you need to change your matte view to “Track Mattes”.
Just select and hold the Mattes button down and three options will be available.

Ah, now I can see it normally. But the object is still not removing. What am I doing wrong?

It depends on how much background you’ve got to use. Is the foreground object always covering any part of the background, or can you get all of your information from the background when the foreground object moves? If not, you will need to use a clean plate to assist the remove.

Here’s the scene: - YouTube
I think there is plenty of background to cover the yellow car.

Are you trying to remove the car, or the person smoking in the foreground window?

Both but for now I’m focusing on the car.

There are a few problems here:

  1. The quality of the video. Since this was shot on a lower res camera with rolling shutter, the frames are going to be warped and grainy, which will contribute to a lower quality remove.

  2. The car is covering a lot of the same background towards the end of the shot that would be used to remove the beginning of the shot. You may need to change your before and after fields to smaller values to accommodate for this.

  3. You will need to mask out the foreground person if this is the only source your have of the shot and not the original. If you don’t mask it out, the Remove module will assume it is part of the background and try to add it to your removal patch.

Without the original high-quality source material however this shot is not easy.

The quality of most of my videos I’ll be working with are low quality. This is why I chose mocha, grain doesnt mess with its tracking unlike other stabilizers and the remove option is a bonus. I can denoise the grain later when everything is stabilized.
That is the original video because I doubt my friend still has that camera let alone the raw footage and we are no longer in contact anyway.
I tried what you suggested in #2, it didn’t work. And I did mask out the foreground person.

Remove is literally doing nothing. Can you describe step by step how to perform the remove so I can make sure everything is in the right order

Here’s a screenshot: Pasteboard - Uploaded Image

Okay, that IS very weird!

Can you please send me the project file and your footage? I’d like to test the situation: martinb {at} imagineersystems.com

Yes, I can do that. But so you know, I did not track the ground plane yet because it refused to ignore the car even though I had it masked out so I wasn’t seeing any evidence of things working right. I hope that if things did work right then the remove would partially work if I didn’t track ground plane.

Right, then that may be why it is not working: You always have to track the background plane, otherwise it doesn’t have the data necessary to remove with and you won’t see anything happen. Try tracking it now and see if you get any change.

Okay I’m dumb, it does appear to work now in the one frame that did the car did collide with the upper matte. But I could’ve sworn that the tracking spline was not ignoring the car when it came in collision with it which made me reshape the spline to avoid the car. This obviously makes my track completely useless for removing and I have to redo everything. But is turning on the “selected track mattes” in view the only way to verify that the masked foreground object is indeed being ignored?
Also, when should I enable/disable the Process and Lock layer controls? While tracking a different area, must the rest have Process enabled or no?

It’s actually best to turn the cogs off for all layers when tracking a new layer, or the other layers will also be tracked.

Process cogs work per-module, so when it comes time to remove, make sure your remove layer cog is turned on, but foreground cogs are turned off (or they will also try to remove).