Disable spline from process

Hi. i create 2 splines : spline1 in layer1 and spline2 in layer2. i want to track the layer1 and i want to mask out area using spline in layer2. If i view the mattes and set to ‘selected track matte’ , when i select layer1 then i can see the visual representation of the area to be tracked which properly displayed : The spline2 will cut out spline1.
Now i want to disable the layer2 . RIght click layer2 and select ‘toggle active’. If i view the mattes to check the area to be track in layer1, i can see no cut out. This is correct.
Now i turn back on the ‘active’ state then hide spline2, by clicking the ‘eye’ icon. Well, if i view the mattes , it shows exactly the same result as if i disable the layer (turn off active). This is wrong…it is really misleading, as i think that there will be no mask. In fact when processing , the mask/matte is still calculated. So in my opinion, if i just hide (eye icon) the layer2 then i should still see the cut out indicating that the area to be tracked will still be masked out.

Hi. i create 2 splines : spline1 in layer1 and spline2 in layer2. i want to track the layer1 and i want to mask out area using spline in layer2. If i view the mattes and set to ‘selected track matte’ , when i select layer1 then i can see the visual representation of the area to be tracked which properly displayed : The spline2 will cut out spline1.

Now i want to disable the layer2 . RIght click layer2 and select ‘toggle active’. If i view the mattes to check the area to be track in layer1, i can see no cut out. This is correct.

Now i turn back on the ‘active’ state then hide spline2, by clicking the ‘eye’ icon. Well, if i view the mattes , it shows exactly the same result as if i disable the layer (turn off active). This is wrong…it is really misleading, as i think that there will be no mask. In fact when processing , the mask/matte is still calculated. So in my opinion, if i just hide (eye icon) the layer2 then i should still see the cut out indicating that the area to be tracked will still be masked out.

Thanks for the feedback! I will talk this over with the devs.
Cheers,
Mary

Thanks for the feedback! I will talk this over with the devs.

Cheers,
Mary