Does Mocha Lens plugin for AE work with AE 22.4 or later on Apple silicon?

I’m using AE 22.4 on a Mac Studio running macOS v12.4, Mocha Pro plugin 2022.5 v9.5.4 .

I have installed the Lens plugin in every possible location (the app Plugins folder, loose and in the Mocha AE folder both; in the Library/…/MediaCore folder, etc.) and it does not appear in my plugins list and there is no paste function in the Edit menu, as there is with Mocha shape. It’s not that it’s grayed out - it’s just not there. I need to undistort many shots and share the lens solves with multiple other artists and would prefer to be able to share the mocha lens text files rather than a clunky solution of saving separate favorite effects files with instances of the Mocha Pro plugin for distort and undistort. Any ideas what I’m doing wrong?
Thanks
Brad

Could you confirm that you tried placing in here, then restart the host?

/Library/Application Support/Adobe/Plug-Ins/7.0/

Confirmed, I tried that as well.

Let me clarify this with the team, and get back to you.

I have to say, Mocha Lens Importer is really not supported on Apple Silicon.
There are couple of workarounds.

  • You can either use STmaps for undistorting & re-distorting process. In case you work with the team of artists, sharing the STmap file is as simple as sharing .txt file

  • You can try running After Effect’s via Rosetta, and the plug-in should work there.

Ah, I had a feeling it was Apple silicon. The lens plugin is very old. Thanks, I’ll be creating ST maps for our Nuke artists and I suppose for our other AE artists I’ll just need to save out .ffx files of the Mocha Pro plugin with the lens module rendering to distort. It works but I wish the lens plugin was functional. Thanks for the help.

1 Like