Drift in After Effects

So I tracked a wall in mocha, did a minor adjustment, and seemed to have a pretty good track. But, when I pasted the data to a null in after effects, I got a lot of drift that I wasn’t seeing in mocha. I’m sure it’s something stupid, but I can’t figure it out. Any suggestions?

—Quote (Originally by MCpare)—
I think i figured it out! I hadn’t changed the position of the anchor point, so I moved it down to where the track was, which fixed the drift in the tracks I had on the floor. Still can’t account for the problems with the wall though. And I tried exporting in corner pin, but it didn’t really work since I only know how to export transform data properly :p. I should probably watch a tutorial on that, but thanks for your help! :slight_smile:
—End Quote—
I just had this problem and here’s what I did to fix it.
I was getting a track shape that matched the first and last frame but had a lot of drift lag in between. My framerate of the comp was 24 and when I brought it into mocha it was 24 as well. Couldn’t figure out what the problem was.
Turns out I had to go right click the footage in my AE bin…select “Interpret Footage → Main” and change it from 30 to 24 in there and THAT finally fixed the drift!

—Quote (Originally by MCpare)—
I think i figured it out! I hadn’t changed the position of the anchor point, so I moved it down to where the track was, which fixed the drift in the tracks I had on the floor. Still can’t account for the problems with the wall though. And I tried exporting in corner pin, but it didn’t really work since I only know how to export transform data properly :p. I should probably watch a tutorial on that, but thanks for your help! :slight_smile:
—End Quote—
I just had this problem and here’s what I did to fix it.

I was getting a track shape that matched the first and last frame but had a lot of drift lag in between. My framerate of the comp was 24 and when I brought it into mocha it was 24 as well. Couldn’t figure out what the problem was.

Turns out I had to go right click the footage in my AE bin…select “Interpret Footage → Main” and change it from 30 to 24 in there and THAT finally fixed the drift!

Great! Definitely check out our videos on our website!

http://www.imagineersystems.com/products/videos

Cheers!
Mary

Hi There,

Check your frame rate, and make sure you are pasting in on the first frame. 9 times out of 10 these sorts of issues come from the clip settings in mocha not matching the comp and clip settings in after effects.

Everything must be the same resolution, the same aspect ratio, and the same frame rate. And everything must be pasted in on the first frame.

Cheers,
Mary

Hi There,
Check your frame rate, and make sure you are pasting in on the first frame. 9 times out of 10 these sorts of issues come from the clip settings in mocha not matching the comp and clip settings in after effects.
Everything must be the same resolution, the same aspect ratio, and the same frame rate. And everything must be pasted in on the first frame.
Cheers,
Mary

Double check. :slight_smile:
Otherwise, what is the exact export you are using? Have you tried the after effects only corner pin?

Double check. :slight_smile:

Otherwise, what is the exact export you are using? Have you tried the after effects only corner pin?

Great! Definitely check out our videos on our website!
http://www.imagineersystems.com/products/videos
Cheers!
Mary

I think i figured it out! I hadn’t changed the position of the anchor point, so I moved it down to where the track was, which fixed the drift in the tracks I had on the floor. Still can’t account for the problems with the wall though. And I tried exporting in corner pin, but it didn’t really work since I only know how to export transform data properly :p. I should probably watch a tutorial on that, but thanks for your help! :slight_smile:

So I tracked a wall in mocha, did a minor adjustment, and seemed to have a pretty good track. But, when I pasted the data to a null in after effects, I got a lot of drift that I wasn’t seeing in mocha. I’m sure it’s something stupid, but I can’t figure it out. Any suggestions?

I don’t think that’s the problem (I used to always mess that up all the time though) because I got good tracks earlier using different parts of the same video in mocha, pasting them into the same after effects composition

I don’t think that’s the problem (I used to always mess that up all the time though) because I got good tracks earlier using different parts of the same video in mocha, pasting them into the same after effects composition

I think i figured it out! I hadn’t changed the position of the anchor point, so I moved it down to where the track was, which fixed the drift in the tracks I had on the floor. Still can’t account for the problems with the wall though. And I tried exporting in corner pin, but it didn’t really work since I only know how to export transform data properly :p. I should probably watch a tutorial on that, but thanks for your help! :slight_smile:

—Quote (Originally by BonoMan)—
I just had this problem and here’s what I did to fix it.

I was getting a track shape that matched the first and last frame but had a lot of drift lag in between. My framerate of the comp was 24 and when I brought it into mocha it was 24 as well. Couldn’t figure out what the problem was.

Turns out I had to go right click the footage in my AE bin…select “Interpret Footage → Main” and change it from 30 to 24 in there and THAT finally fixed the drift!
—End Quote—
What fixed it completely for me was to just make a new composition with exact same footage. Using the same track I was having problems with, it worked perfectly in the new composition. I don’t know why, but I have what I needed so I’m not going to worry about it :stuck_out_tongue:

—Quote (Originally by BonoMan)—
I just had this problem and here’s what I did to fix it.
I was getting a track shape that matched the first and last frame but had a lot of drift lag in between. My framerate of the comp was 24 and when I brought it into mocha it was 24 as well. Couldn’t figure out what the problem was.
Turns out I had to go right click the footage in my AE bin…select “Interpret Footage → Main” and change it from 30 to 24 in there and THAT finally fixed the drift!
—End Quote—
What fixed it completely for me was to just make a new composition with exact same footage. Using the same track I was having problems with, it worked perfectly in the new composition. I don’t know why, but I have what I needed so I’m not going to worry about it :stuck_out_tongue: