Driven Crazy by Magic Mouse Scrolling


#1

 

Am I the only person using Mochae AE that is going absolutely batty trying to use Apple’s Magic Mouse? Every time my finger moves a nanometer on the surface of my mouse, the entire timeline scrolls and Mocha automatically makes dozens of keyframes for me. And hitting Undo does nothing to help.

I wrote an Apple Script that automatically turns off scrolling on my mouse when I’m using Mocha, and it still happens! I wish there was a way to disable Mouse Scrolling from within Mocha. Until then, I literally need to plug a different mouse into my computer whenever I’m using Mocha.

Has anyone else experienced this? Does anyone have any solutions or workarounds? Thanks in advance.


#2

We’ve seen similar problems before with the Magic Mouse. Unfortunately we have no customisation for mouse shortcuts, only keys.

My suggestion for the time being is to install Magic Mouse configuration tools like MagicPrefs or BetterTouchTool and customise it to turn off scrolling preferences just for mocha.


#3

Hi Martin,

Thanks for the quick response! Unfortunately MagicPrefs doesn’t let you link scrolling per-application, only the non-scrolling settings. To deal with that, I’ve created a hot-key-activated AppleScript that will let me disable all scrolling when I’m using Mocha. For some reason I am STILL getting the scrolling.

I recorded my screen to show you: https://dl.dropboxusercontent.com/u/31926492/Mocha%20Scrolling.mov

You’ll see 13 seconds into the video I disable my scrolling. Then when I drag points on a mask around, with my finger slightly brushing against my Magic Mouse, the timeline cursor flies all over the place creating random keyframes.

Would it programmatically be possible to tell Mocha AE not to react to mouse-scrolling? Does anyone actually use this feature? Seems like linking mouse scrolling and the timeline cursor would lead to pretty inaccurate movements. And of course it’s a different function than what After Effects does with scrolling, which is an equally frustrating, though more difficult to trigger, zooming in and out of the canvas.

Thanks in advance for any thoughts on this.


#4

In the long term we will allow customisation for the scroll wheel, but for mocha AE at present unfortunately there probably isn’t much we can do.
The Magic Mouse isn’t a standard input device, so it’s hard to predict what it will do in regular circumstances where a scrolling wheel would normally be used.

Do you have a Macbook or desktop Mac?

Out of interest, does MagicPrefs actually stop the scrolling compared to your script?


#5

Thanks again Martin for the reply.

I use a late 2012 27" iMac. My script actually does use MagicPrefs to disable scrolling. I set it up as a system Service so I can quickly run it with a hot key. Here’s what it looks like:


set CloseSystemPreferencesAfterScript to true // Use this to not disrupt the current state of the System Preferences application

if application “System Preferences” is running then
set CloseSystemPreferencesAfterScript to false
end if

tell application “System Preferences”
reveal pane "MagicPrefs"
end tell

set ScrollingActivated to true

tell application “System Events” to tell application process “System Preferences”
click button “Configure Scrolling” of group 2 of window “MagicPrefs” of application process “System Preferences” of application “System Events”
set theCheckbox to checkbox “Diagonal” of list 1 of sheet 1 of window “MagicPrefs” of application process “System Preferences” of application “System Events”
tell theCheckbox
set ScrollingActivated to value of theCheckbox as boolean
end tell
click checkbox “Diagonal” of list 1 of sheet 1 of window “MagicPrefs” of application process “System Preferences” of application “System Events”
click checkbox “Vertical” of list 1 of sheet 1 of window “MagicPrefs” of application process “System Preferences” of application “System Events”
click checkbox “Horizontal” of list 1 of sheet 1 of window “MagicPrefs” of application process “System Preferences” of application “System Events”
click checkbox “Diagonal” of list 2 of sheet 1 of window “MagicPrefs” of application process “System Preferences” of application “System Events”
click checkbox “Vertical” of list 2 of sheet 1 of window “MagicPrefs” of application process “System Preferences” of application “System Events”
click checkbox “Horizontal” of list 2 of sheet 1 of window “MagicPrefs” of application process “System Preferences” of application “System Events”

click button “Close” of sheet 1 of window “MagicPrefs” of application process “System Preferences” of application “System Events”
end tell

if CloseSystemPreferencesAfterScript then
tell application “System Preferences” to quit
end if

if ScrollingActivated is true then
display dialog “Scrolling OFF” buttons {“OK”} default button 1 giving up after 1
else
display dialog “Scrolling ACTIVATED” buttons {“OK”} default button 1 giving up after 1
end if


 


#6

Hi, I registered purely to voice my frustration on this issue!

I’m teaching rotoscopin in Mocha at a local college with about 10 students and EVERY machine has a Magic Mouse and the students are going bonkers because of this! There must be a solution that Imagineer Systems can come up with?? Couldn’t you just have a checkbox saying ‘Disable Mouse Scrollwheel’ and when you tick that, the sensitivity of the wheel is changed to 0 within Mocha?? Surely Apple gives developers the ability to change mouse wheel sensitivity within their apps??

Please, Imagineer Systems, come up with a solution to this issue!

Thanks,

PJ


#7

There is a related issue that I find very frustrating: scrolling to navigate through the clip. When the mouse is hovering over the timeline itself, scrolling right moves forward in time and scrolling left moves backward in time. When hovering over the image, however, scrolling right moves backward in time, and scrolling left moves forward in time. (Scrolling up and down work the same in both instances, however.) Is there a reason for this, or is it simply part of the Magic Mouse weirdness?


#8

That sounds like a bug to me, whether on our end, or the magic mouse end we will need to test.

Right now we have the request to customise the scroll wheel in our feature request list, but unfortunately I can’t guarantee when it will get into a release.


#9

What has helped me as a temporary fix that YOU can do while we wait for an update is to simply just keep your index planted on the mouse while you’re moving around fixing points and other things. It’s worked relatively well for me but can be a little straining after a while. Hope that this has helped a little!


#10

I have also been experiencing this issue with the Mocha Pro Plugin… it has made roto work very straining and overly time consuming. It’s been awhile since this problem was pointed out-- an option to turn off mouse scrolling would be an extremely helpful feature. Thanks!