Error: export tracking data from mocha AE in AE


Hello together,
I’m Matthias from Germany and 17 yeras old. I had the following problem:

After finishing tracking a wall in mocha ae (see pic 1, that works absolutly fine and correct!)

I clicked on “Export Tracking Data…” in the window, that opens after clicking, I chose “After Effects Transform Data (position, scale and rotation)” than “copy to clipboard” (See pic 2!).

Back in After Effects I go to the first frame, create a null-object and paste the transform data at the null-object. BUT the tracking points are of screen so outside of the clip (see Pic 3!)

and when I connect a bullet hole to the null-object, it moves more than before. In mocha ae the it works fine, but not in ae.

I need that for my Study work, so it would be great if somebody could help me…

Many thanks forward

Matthias L.


Hi Matthias,

I don’t see any attached pictures, but this is probably a data mismatch.

When you paste or import your mocha data into the final composite or edit, make sure you are pasting or loading your data in at the first frame of the clip, otherwise your data will not line up.

Project settings such as frame rate, dimensions and pixel aspect ratio must be match between your mocha project and your destination software. Make sure these values match the settings in your compositor or editor and inside of mocha, otherwise your tracking data will not match when you export it.


If your are using Adobe After Effects, the target layer you are pasting data to should also be the same size as your AE composition. A good After Effects troubleshooting tip: create a new solid that is the same size as your composition. Paste your track or roto shape data to this layer. If it does not line up, the issue is mostly likely a project mismatch.


Hi Mary,
thank you for your quick answer.

The Roh Clip Resolution is 4096 x 2160
In Pr I take 1920 x 800
In Ae is shown 1920 x 800, but roh Clip is shown 4096 x 2160 and mocha is the row-resolution I think!
I made a Test:
When I take the Clip directly in Ae and make the same steps in mocha and export the tracking Data to Ae it works great!
So the problem must be the resolution.
Can I do any settings (in mocha)to solve the problem?

Thank you very much…

Matthias L.


Hi Matthias,

Go to file>project settings and change the resolution. As long as mocha is set with an aspect ratio of 1 (square pixels) you should be able to copy the data from there and make it work. If the aspect ratio is off, you will have to retrack at the right aspect ratio and you might as well change the resolution then too.



Hi Mary,

thank you for your kindly, great and quick support…

Matthias L.


Hi Mary,

sorry, but I can’t change the resolution in mocha as you wrote.
When I go after klick in Ae “track in mocha” there in the project settings in mocha I Can only see the General settings:
Length (frames) 1068
First Frame offset: 0
Frame Rate: 24

There is no possiblity to change anything and the resolution is not shown there.

Or understood I something wrong?






Hi Matthias,

That’s going to be in newer version, in older versions you should be able to change this in the clip tab instead.

You can also change them in After Effects.




Hello Mary,
I think I have the same problem as Matthias. However, I cannot find where to change the resolution etc. Like Matthias, I must have the old version with general settings under file. Where do I find the clip tab? I’ve attached a screenshot. Thank you!


You need to be able to see the modules, so right beside where it says “track” it will say “clip” on the lefthand side. It’s not visible in your screenshot.