Error: Failed to compute layer homography

Hi there, I had problems with tracking a crosswalk in my project. I used the Mocha AE to track the crosswalk, it looks perfect in Mocha, but part of the footage cannot show the solid layer I linked. I attached the image below as the picture shows that the surface frame throws off the grid area. I am wondering is that the reason why after importing into after effect, the solid layer cannot be shown. Any solutions for me? Thanks ahead

@user130 Hi, did you track the woman separately & put that track at the top of the list so when tracking the crosswalk she is excluded,
also that top spline is tracking the path & the shop front, they are 2 different planes & need separate splines,

Thanks. I haven’t tracked the woman separately yet, will try it. Btw, do u have any clues that why I keep receiving the notice like, failed to compute the layer tomography?

Hi, no sorry, i had to Google Tomography but the answers are mainly to do with layers or planes,
so because Mocha is a planer tracker that makes sense, it’s saying it can’t do what you’re asking trying to track that plane, i think,
Everything i’ve coloured in is a different plane & needs to be tracked with a different spline, (& people are lot’s of planes because they aren’t flat & they’re moving)
if a spline overlaps planes like in your pic it will ad a skew type action to the tracking,
so in this pic there are at least 10 different panes, & depending on the camera movement i suspect the path would have to be split into different planes where it slopes down to the crosswalk. (& poss even the different shop fronts & doors would have to be separated)
You only need to draw a rough outline around that woman, track her, put her at the top of the list & turn off tracking for her, then track the crosswalk, putting her at the top of the list Mocha will ignore her when tracking the crosswalk.


Sorry, my bad. Its Homography. I did exactly what you said, but the same problem still happened


and I can’t adjust the red lines cos the ‘‘failed to compute the layer homography’’ warning will pop out.

Did you turn off tracking for the woman when tracking the crosswalk,

& the spline for the woman needs to be bigger & inc every bit of her, more like this

:+1: my answer would be similar to Tomography :grin:

The surface is coming out past the calculatable area, that’s why you get that error. I’d try breaking the track up into sections maybe. In Mocha, this is a “surface behind the camera” issue.

1 Like