Error launching Particle Ilusion from Optics 2022

Hello
I just purchased an update from my Optics program to have the 2022 version with Particle Illusions inside. When i try to launch the PI from inside Optics I get this error (screenshot attached) It says: Continuum 2022 15: Particle Illusion UI communication failure Error code: -1 Unable to connect to Particle Ilussion
Error
I have the suspicion that it might somehow enter in conflict with my Continuum 2021 software that I have installed in Davinci Resolve. As it is not the latest 2022 version (and right now I dont want to update as I am not video editing that much at this time)
Do you think this is the problem or is there something else at play here?

Thank you for your support

Cristian

@mastix PI within Optics is self contained, so I don’t think the issue is with Continuum 2021. I would try completely uninstalling, restarting and reinstalling. Let me know if that clears it up for you.

Ok I will also uninstall Optics 2021 just in case it conflicts with 2022

Unfortunately uninstalling Optics 2021 and Optics 2022 and only reinstalling the 2022 version did not solve the problem. I am getting the same error and problem

@mastix It looks like you are on Windows. Can you please do the the following?

  • In the search box on the taskbar, type regedit, then select Registry Editor
  • Go to HKEY_CURRENT_USER\SOFTWARE\BorisFX
  • Right click on the entry for Particle_Illusion, and select Export to save a copy to the desktop.
  • Delete the Particle_Illusion folder
  • The prefs will be reset to defaults on next relaunch of Particle Illusion.
  • If this helps please send us a zipped copy of the faulty prefs file exported to desktop for analysis.

Zipped registry

Unzipped registry file

Hello.
I did as you said with the same error. It did not fix the problem
I send you the link so you can download the registry files you asked for (zipped and unzipped)

It would be best to file a support case at: Boris FX | Open a Case Support will most likely need to do a remote session on your machine to solve the issue.

1 Like

Thank you. I opened a case as suggested. Thank you for your help

Just to let you know that I have the same problem on windows. I will also raise a case.

Hi Cristian did you get any solution that worked yet. I have also opened a case and not got a satisfactory solution. All gone very quiet. Regards Tom

@Tom326 In addition to deleting the PI preferences (instructions were sent to you by support) try resetting the Photoshop preferences: Preferences in Photoshop

Thanks Marco. Problem was PI stand alone upgrade to 2022. Had to delete it and now everything works. Problem came up also on launching Optics 2022 as stand alone. So not a PS problem. Suggested PI 2022 for Windows needs looking at as some sort of issue.

To confirm, once the Standalone version of PI 2022 was removed, the PI user interface opened from Optics, correct?

Yes that is correct. I removed stand alone PI 2022. Deleted the prefs in the registry, restarted and it worked.

Thanks @Tom326 We’ll take a closer look.

Just to update Marco. I have reloaded PI stand alone and all seems to be working fine. Maybe the order of installing was the issue, not sure.

I have both versions installed on my machine and don’t have an issue. Not sure what is going on.

Hi Marco after sending you the last note saying it was all working well it is not and ‘I am beginning to lose the will to live’. I cannot launch PI from Optics again and I have deleted all prefs and uninstalled and installed the programs 3 times. Nothing will work to get PI to launch. Also when I use PI stand alone and build my own emitter it closes the program when I try to save the emitter in my library. Also it seems weird that when I install PI from brand new I also get my TomF library. How can this be on a fresh new installation? Surely it should default everything to ‘factory settings’. I was going to purchase PI as a plug in for Adobe but feel I will be wasting my money with all of these issues. Are other people having these sort of issues and can they be permanently fixed?

@Tom326 I believe you need to restart your machine after removing the preferences. Also, the preferences should be saved before deleting them and given to customer support so the file can be examined to determine the root of the problem. If you are willing, I suggest continuing with customer support to come to a resolution. As far as your TomF library, it is probably stored in a your user folder somewhere and that is why you are seeing it. For what it is worth, two QA engineers spent Friday afternoon trying to replicate the problem without success.

Hi Marco, thanks, I have done all you have said. I even deleted every program and folder/file that had Boris FX including all preferences and Log folders. Then I downloaded each program starting with Optics 2022. I get the odd successful launch of PI from Optics but most fail with the error message. I have today loaded Optics 2022 into my laptop which also runs on Windows 10. Everything is working fine on the laptop. I now think the problem lies with my Desktop PC but where who knows, it is only 1 year old, with 32Gb RAM and all solid state drives and pretty fast Intel i9. I notice the Nvidia graphics card I have is not on your approved list though. I have the GTX1600Super with 6Gb of DDR. Could that be the issue? Are you aware of any programs that can interfere with Optics operation? Can firewalls be a problem?

I need to be able to make changes to the emitters inside Optics but obviously I am unable to do that as I cannot launch PI. I can however make the changes in the stand alone PI. Is there any way I can get these presets/emitters from the stand alone my library/custom library into the Optics library? I cannot see any obvious way.

I will continue to try to find the fault but if any of your engineers could help I would appreciate it. Is there anyway I can try the PI plug in version for Adobe to see if it works? If it does I will purchase straight away.

Regards Tom