Error Message: Your system has run out of application memory


#1

Render times have become a point of failure in my project.

Editing a doc, with lots of stills. Using BCC Pan And Zoom extensively. No other items require rendering in the timeline except for a limited number of titles and a burnin on the top layer.

Some setup background.
Avid Media Composer 2018.10 (and 8.5)
BCC 12 (and 11, now 10)
MacBookPro 15" retina mid 2014
2.8 GHz i7
16 GB RAM
Storage: 4 TB lacie with 300 GB remaining.
Internal: 500 GB, 180 GB remaining.

macOS 10.12.6 Sierra

At some point in the last two days, trying to make a output of a 20 minute timeline fails when the os posts a message “Your system has run out of application memory.” It suggests quitting any unused application, but Media Composer is the only application running. The message is presented in the Force Quit window, and shows the Avid Media Composer app “Paused”.

I’ve previously had no problem exporting this sequence. It would take 30 minutes or so to render and output. This failure is new. I’m now rendering each BCC P And Z individually. A 2 second clip took 5 minutes to render.

I am at a loss. I’ve created a new sub sequence to render sections. Tried video mixdown of sections. Created a new project and opened a copy of the timeline there.

I’ve moved the project to another drive and to another computer, an upgraded Mac tower. Subclipped out only the video tracks, to eliminate any possible audio clip error.

Changed versions of Media Composer and BCC.

If I try to render more than a clip or 3 at a time it fails.

Any ideas would be greatly appreciated.

  • Harry

#2

Are the still images being used larger than before? Pan and Zoom temporarily caches raw, uncompressed versions of the still image sources so it can render quickly. If you cycle through a number of different high rez stills in a short period of time then that cache could potentially grow quite large and this may be overwhelming the available 16GB memory on that system. You could try to temporarily swap in smaller versions of the images just to see if using a proxy bypasses the problem. What’s confusing is that you say the same sequence used to work but now it fails with multiple versions of Continuum and multiple versions of Avid. Can you think of anything else that has changed such as amount of RAM on the system or the size of the still images in use?


#3

That is a great tip. I’d gone back to BCC 10. When I replaced the Pan and Zoom with a new one, the render was fine. So I went back to BCC 12, thinking maybe it was something in the beta. I tried your suggestion of pointing to another version of the shot, then back to the correct one.

What I’ve just discovered is if I re-point to the original file, then render time for a 3 second shot goes from 2:40 to :08!

It must be something to do with creating a watch folder that is so complex, it is doing too much searching. That is all I can think of. I’m going to move those images to a smaller folder and see what happens.

Thanks for the great idea.


#4

That worked! I moved the Watch folder out of the massive Sills folder and pointed to it rather than the Stills folder. Render times are back to normal.

Whew. I’m delivering today. This helps a lot.


#5

Glad you’ve found a workaround. This certainly seems to point to a problem though. Having the Watch Folder point to a deep folder shouldn’t make that big a difference in terms of render time. And it definitely shouldn’t cause Out of Memory errors. When you get a chance it would be great if you could help us understand your watch folder setup. E.g. how many levels deep of subfolders did it have? How many total files were in it? Was it on a network drive or an internal drive?


#6

I pointed to the folder on an external drive, _Stills. It resides in a larger folder, Media.

I’ve attached a screen grab. A search tells me there are around 7013 total image files. The important watch folder, with the cleaned and final images, has 81 images. But not all images needed for the timeline are in that finals folder.

Some of the folders within _Stills have subfolders. A couple have multiple subfolders.


#7

Thanks, Harry. Nothing there looks out of the ordinary. We’ll experiment to try to reproduce here. I have theories as to why there might be performance issues in your situation, but I can’t explain the out of memory errors.


#8

This was happening on two different computers, with two different external drives, with various versions of BCC. I would be happy to test anything that would help.