Error Opening Emitter Library

I purchased Boris FX Continuum through Filmora and have been using it about 4 months. This week, I started working my way through the YouTube series from Boris FX - Getting Started with Particle Illusion. I noticed I don’t have all the emitters in the videos, so from within Particle Illusion (which I had opened through Filmora), I chose Help-Download Emitters. Now I have an error message when I open from within Filmora (my typical workflow):

Error opening emitter library: C:/ProgramData/BorisFX/EmitterLibraries/Emitters_2022.5.il3 This emitter library may have been modified in a newer version of Particle Illusion, or it may be corrupted.

I can continue past this error message and use PI for a bit (with lots of new emitters), then PI crashes and I lose my work. How can I fix this?

Thank you!
MelRae

Hi,
Check your Continuum is up to date, Boris App Manager will help