Everything looks great in Mocha but not rendered in Premiere Pro

Hello, I just purchased Mocha Pro and followed this tutorial.

I rendered it and it looks perfect! But then, after it hit the end of rendering, I check them again from the beginning and the part that is already rendered says “this frame is not rendered in Remove input”. Some other parts still remained rendered.

I saved it and close Mocha, and go back to Premiere Pro.

In the tutorial video, she is making another layer of the video but I am not sure how she did it.

I hit Render in Remove, apply feather, etc, but the video is still in original status. I check Apply Matte, and it goes all black, not like in video, which shows the removal section visible with everything else black.

What am I doing this wrong. It would be great if someone can help asap!


It depends on what you are removing, but you do sometimes need to wait a moment for the render on the Premiere timeline.
Can you show a screengrab of your Mocha remove module setup, please?

OK, I tried again and am waiting now without touching Premiere Pro. Let’s see…

Also, how can I match the lighting of the cleanplate and the original throughout the video? The person moves so the lighting on his face changes. And when it changes, the cleanplate becomes different brightness and stands out from the rest.


You can use linear or interpolation lighting modes in the remove, but it will depend on if the shape is touching other darker shadows as to how it will perform.

Hi, thanks for your response! I actually did try using linear or interpolation lighting modes but it still does not blend in… So I thought maybe there is another way to do it… It’s not like there are dark shadows though. The lighting is very similar throughout the video and he is not in direct sunlight, but because of the angle of his face and also the light from the window, the brightness on his face changes.

Have you tried blending the results back in with a lot of feathering?

If you have hard shadows going across the face, or super bright highlights, however, linear modes will not work. You might have to hand animate some linear color shifts over time with a color corrector, but that’s built into premiere.

Hello, I actually cannot even go to that point because of some kind of error. I thought maybe feathering would help blending, but when I save it in Mocha and go back to Premiere Pro, nothing happens to the original video. So no way I can apply feathering, sadly.

As martinb suggested, I waited for 4 hours after I saved Mocha and clicked Render in Premiere Pro, but absolutely nothing happened on my video. It’s just same as the original…

If that’s the case just render in Mocha Pro and export the video, drop it back into your timeline as a workaround. You can still use Mocha to apply the mask on that too if you need to.

Exporting clip also does not work… it gives me error…

What error? What type of export? Most common errors are not setting a keyframe with the movie export. Can you set a keyframe every frame and try again?

I did Export Rendered Clip and it gives me this error. Keyframe has already been set if I rendered them, right? I watched the YouTube tutorial and tried many times but still doesn’t work.

I sent a log file though support and he said they’ll be working on it to find out what’s causing it…

You’ve been very helpful. Thank you!

A screen grab of your remove parameters would be most helpful to glean what is going on. By this I mean the whole screen of your Mocha remove module

Hi, I am still waiting for customer support to respond to me. I understand you guys are closed for weekends, but today is Tuesday afternoon in Australia, right? I don’t get a reply back to my email I sent last Friday (Saturday in Australia). I am still having this issue and unable to use Mocha. Can anyone help me please? Thanks.

Let me see if I can find your case and see who has it assigned to them.

Hi, thanks for getting back to me. I received a reply. Hopefully I’ll be able to solve it tonight (night in NY, day in Australia)…

Hi, I finally figured it out with a remote session on Tueday night. It was because there was a Warp Stabilizer layer on top of the Mocha layer.

So, that is that, and now I am having another issue. Mocha is suddenly taking 5 min to render 1 frame.

I haven’t been able to make good transition with 1 cleanplate, so I added multiple cleanplates, but they it looks like it suddenly jumps to another image, so it doesn’t work.

Do you have any suggestions on above 2 issues?


By the way, before, it was only taking a few seconds to render 1 frame. I restarted the computer but still taking 5 min to render.

It might actually be because it’s trying to use 3 different cleanplates into 1 frame. I tried to blend 3 cleanplates once but it didn’t look good so I stopped and I got rid of the cleanplates but it’s still showing 3 images rendered in 1 frame. How can I get rid of them completely?

Can you try clearing your cache, deleting your cleanplate clip, and reimporting your cleanplates (making sure you set them to the proper frames they blong on)? Sometimes resetting it helps. Can you also screenshot your settings? If you’re using cleanplates, click the “use cleanplates exclusively” checkbox for faster rendering.

OK thanks. Selecting use cleanrplates exclusively made it faster.

Now how can I easily select mutiple frames at once? Like when you are selecting documents in Finder in Mac, you can SHIFT click to select multiple documents. Is there a way to select multiple frames at once like that in Mocha? I am trying to assign image 1 to frame 0-204, image 2 to frame 205-305, image 3 to frame 306-406, etc.